VirtualBox

Ticket #3888 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

clonehd documentation is incomplete

Reported by: harmscon Owned by:
Priority: minor Component: documentation
Version: VirtualBox 2.2.2 Keywords: clonehd ERROR Cannot register the hard disk
Cc: Guest type: other
Host type: other

Description

The documentation for the VBoxManage clonehd is incomplete. <filename> must be given as an absolute filename (ie, including the full directory path). See below for an example. This should either be specified in the User Manual or the behaviour of clonehd updated to suit the documentation.

jaba@host:~/test-20090302$ VBoxManage clonehd test_virtual_machine.vmdk test_vm-clone.vdi --format VDI
VirtualBox Command Line Management Interface Version 2.2.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

ERROR: Cannot register the hard disk '/home/jaba/test-20090302/test_virtual_machine.vmdk' with UUID {af38d7f6-a3e0-448a-95a9-4a06ab5e07bc} because a hard disk '/home/jaba/test-20090302/test_virtual_machine.vmdk' with UUID {af38d7f6-a3e0-448a-95a9-4a06ab5e07bc} already exists in the media registry ('/home/jaba/.VirtualBox/VirtualBox.xml')
Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports
Context: "OpenHardDisk(Bstr(szFilenameAbs), AccessMode_ReadWrite, srcDisk.asOutParam())" at line 603 of file VBoxManageDisk.cpp
jaba@host:~/test-20090302$
jaba@host:~/test-20090302$
jaba@host:~/test-20090302$ VBoxManage clonehd /home/jaba/test-20090302/test_virtual_machine.vmdk test_vm-clone.vdi --format VDI
VirtualBox Command Line Management Interface Version 2.2.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Clone hard disk created in format 'VDI'. UUID: 78a13ccd-bc74-4f12-ae85-f2a993678f9e
jaba@host:~/test-20090302$ 

Thanks to marten in the forums for solving this.

Josh

Change History

comment:1 Changed 5 years ago by misiu_mp

Notice the error message: Cannot register the hard disk '/home/jaba/test-20090302/test_virtual_machine.vmdk' with UUID {af38d7f6-a3e0-448a-95a9-4a06ab5e07bc}

because a hard disk '/home/jaba/test-20090302/test_virtual_machine.vmdk' with UUID {af38d7f6-a3e0-448a-95a9-4a06ab5e07bc}

already exists in the media registry ('/home/jaba/.VirtualBox/VirtualBox.xml')

Why is it not recognizing it is the same file with the same UUID and just ignore the attempt?

This bug is not just in documentation. Clonehd shouldnt require supplying a full path.

comment:2 Changed 4 years ago by sorin

Someone with proper permissions should change the title/description of this bug and give it the right priority. Documentation is only half of the bug.

The bug is still present in 3.0.8 and combined with the very ambigous error message it does create a real bad user experience.

The only workaround is to search on net and find solution posted on the net by other users, like  http://muffinresearch.co.uk/archives/2009/07/23/virtualbox-error-cannot-register-the-hard-disk/

comment:3 Changed 3 years ago by ibboard

#6367 appears to be a separate ticket about the technical aspects of the bug, but it seems to have been closed as a duplicate of an unrelated bug...

I've just encountered this same bug in the latest pre-releases of v4 (from the openSUSE build service repository for openSUSE 11.3)

comment:4 Changed 3 years ago by jss

I'm with 3.2.12 on Ubuntu 10.10 and just noticed this bug. Only solved it by googling to this ticket; hard to believe it's more than one year old, is it a regression? Nevertheless, thank you for a very good piece of software.

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

That will be finally fixed in the next maintenance release. The parsing of the filename was changed at some time because doing so looks more correct. You now have to specify the filename either as an absolute path or the filename must reside in the current directory.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use