VirtualBox

Ticket #10331 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

VBox 4.1.10 Windows 7 x64 Guest consistently crashes

Reported by: coolmuse Owned by:
Priority: major Component: WDDM
Version: VirtualBox 4.1.10 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Fresh install of Windows 7 SP1 x64 into a VM. Running with experimental Direct3d WDDM driver enabled. Reliably crashes when performing extensive I/O (some combination of network and disk). In the the case of attached vbox.log, I was simply cloning a mercurial respository from an HTTPS network location to a drive mapped to a VBox Shared Folder location on the host file system.

Turned off the 3D Enabled option in the VM Display settings of the VBoxManager GUI, and system appears to be stable after performing the same operation.

Attachments

VBox.log Download (207.4 KB) - added by coolmuse 2 years ago.
VBox log
VBox.png Download (13.0 KB) - added by coolmuse 2 years ago.
VBox meditation guru screen shot
VBox2.log Download (78.2 KB) - added by coolmuse 2 years ago.
vbox3dump.zip Download (76.4 KB) - added by coolmuse 2 years ago.
Crash dump and vbox log files
vbox4dump.zip Download (52.3 KB) - added by coolmuse 2 years ago.
Minidump after upgrading to 4.1.12

Change History

Changed 2 years ago by coolmuse

VBox log

Changed 2 years ago by coolmuse

VBox meditation guru screen shot

comment:1 follow-up: ↓ 2 Changed 2 years ago by coolmuse

I've re-updated the Vbox Guest Additions to ensure they are 4.1.10. So far so good.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 2 years ago by misha

Replying to coolmuse:

I've re-updated the Vbox Guest Additions to ensure they are 4.1.10. So far so good.

Do you see no problems after 4.1.10 additions re-installation with 3D enabled and Aero running as well?

comment:3 in reply to: ↑ 2 Changed 2 years ago by coolmuse

Replying to misha:

Replying to coolmuse:

I've re-updated the Vbox Guest Additions to ensure they are 4.1.10. So far so good.

Do you see no problems after 4.1.10 additions re-installation with 3D enabled and Aero running as well?

Yes. I turned 3d enabled and Aero back on, and was deleting a large number of files (~50K) through a VirtualBox Shared folder when it crashed again after running for about 1.5h. The meditation guru dialog did not appear after the VM restarted itself. I've attached vbox2.log.

Version 1, edited 2 years ago by coolmuse (previous) (next) (diff)

Changed 2 years ago by coolmuse

comment:4 follow-up: ↓ 5 Changed 2 years ago by misha

Could you attach a minidump for the crash here? See https://www.virtualbox.org/ticket/9267#comment:36 on how to enable dump generation on application crash.

Changed 2 years ago by coolmuse

Crash dump and vbox log files

comment:5 in reply to: ↑ 4 Changed 2 years ago by coolmuse

Replying to misha:

Could you attach a minidump for the crash here? See https://www.virtualbox.org/ticket/9267#comment:36 on how to enable dump generation on application crash.

Done. vbox3dump.zip should have the vbox log files and minidump generated by Windows Error reporting service. Let me know what else I can provide.

comment:6 Changed 2 years ago by misha

  • Component changed from other to WDDM

Thanks for the dump. We will investigate it and fix the issue..

comment:7 follow-up: ↓ 8 Changed 2 years ago by misha

I guess this is SMP-related problem, i.e. possible duplicate of #10200. Could you please try assigning 1 CPU instead of 2 to your guest and see if it solves the problem?

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 2 years ago by coolmuse

Replying to misha:

I guess this is SMP-related problem, i.e. possible duplicate of #10200. Could you please try assigning 1 CPU instead of 2 to your guest and see if it solves the problem?

I'll try this later today.

comment:9 in reply to: ↑ 8 Changed 2 years ago by coolmuse

Replying to coolmuse:

Replying to misha:

I guess this is SMP-related problem, i.e. possible duplicate of #10200. Could you please try assigning 1 CPU instead of 2 to your guest and see if it solves the problem?

I'll try this later today.

Misha, after changing to one CPU and turning 3D enabled back on, I am unable to reproduce the problem. I would be happy to test any potential fixes.

comment:10 Changed 2 years ago by frank

The Guru Meditation you saw in the first log will be fixed in the next maintenance release.

comment:11 follow-up: ↓ 12 Changed 2 years ago by frank

Could you check if you still experience these crashes with VBox 4.1.12?

comment:12 in reply to: ↑ 11 ; follow-up: ↓ 13 Changed 2 years ago by coolmuse

Replying to frank:

Could you check if you still experience these crashes with VBox 4.1.12?

Sure. I'll try upgrading later today.

Last edited 2 years ago by coolmuse (previous) (diff)

Changed 2 years ago by coolmuse

Minidump after upgrading to 4.1.12

comment:13 in reply to: ↑ 12 Changed 2 years ago by coolmuse

Replying to coolmuse:

Replying to frank:

Could you check if you still experience these crashes with VBox 4.1.12?

Sure. I'll try upgrading later today.

Hi Frank,

No luck. Upgraded to 4.1.12, installed new extensions, turned on 3d acceleration, and I was able to replicate the problem as before. I have attached vbox4dump.zip which contains the vbox.log and the minidump.

comment:14 follow-up: ↓ 15 Changed 2 years ago by misha

We've fixed an issue that caused guest crashes on SMP systems. Please give a try to this test build of VBox Guest Additions and let me know whether it solves the issue for you:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.1.13-77291.iso

comment:15 in reply to: ↑ 14 ; follow-up: ↓ 16 Changed 2 years ago by misha

  • Status changed from new to closed
  • Resolution set to duplicate

This bug is actually a duplicate of #10200, so I will mark it as such.
Like I mentioned in comment 14, it has been fixed, and the fix is confirmed in bug 10200 discussion.

comment:16 in reply to: ↑ 15 Changed 2 years ago by coolmuse

Replying to misha:

This bug is actually a duplicate of #10200, so I will mark it as such.
Like I mentioned in comment 14, it has been fixed, and the fix is confirmed in bug 10200 discussion.

Thanks Misha. I finally got around to testing Additions 4.1.13; so far everything is stable. Thanks again!

comment:17 Changed 2 years ago by misha

Glad to here, thanks a lot for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use