VirtualBox

Ticket #10288 (closed defect: worksforme)

Opened 2 years ago

Last modified 2 years ago

VirtualBox cannot start guest VMs

Reported by: tkral Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

A few days ago I had to do a hard reboot with VirtualBox running and some VMs started. Now, VirtualBox cannot start a VM at all. I've tried upgrading to 4.1.8 and then I purged VirtualBox from my system and re-install but with the same results. I found the trace given below with demsg. I've also attached the VBox logs from my latest attempt. Not sure that this is necessarily VirtualBox related, but any idea about what the issue is?

Thanks.

[ 409.027134] vboxdrv: Found 12 processor cores.

[ 409.027345] VBoxDrv: dbg - g_abExecMemory=ffffffffa0dcb3a0

[ 409.027444] vboxdrv: fAsync=0 offMin=0x248 offMax=0x14f5

[ 409.027485] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.

[ 409.027486] vboxdrv: Successfully loaded version 4.1.8 (interface 0x00190000).

[ 409.244175] vboxpci: IOMMU not found (not compiled)

[ 898.036334] general protection fault: 0000 #1 SMP

[ 898.036338] last sysfs file: /sys/devices/system/cpu/cpu11/online

[ 898.036339] CPU 8

[ 898.036340] Modules linked in: pci_stub vboxpci vboxnetadp vboxnetflt vboxdrv binfmt_misc isofs vmnet vmblock vsock vmci vmmon xt_state bridge stp kvm_intel kvm snd_hda_codec_analog ipt_REJECT xt_tcpudp snd_hda_intel iptable_filter snd_hda_codec snd_hwdep ipt_MASQUERADE snd_pcm_oss snd_mixer_oss iptable_nat nf_nat snd_pcm nf_conntrack_ipv4 nf_conntrack snd_seq_dummy nf_defrag_ipv4 snd_seq_oss ip_tables snd_seq_midi snd_rawmidi snd_seq_midi_event x_tables snd_seq nvidia(P) snd_timer snd_seq_device fbcon tileblit font bitblit softcursor dell_wmi snd vga16fb ppdev soundcore lp parport_pc vgastate parport psmouse serio_raw snd_page_alloc dcdbas usbhid hid usb_storage raid456 async_pq async_xor xor async_memcpy async_raid6_recov raid10 raid6_pq e1000 ahci async_tx tg3 raid1 raid0 multipath linear

[ 898.036372] Pid: 6994, comm: VirtualBox Tainted: P 2.6.32-38-generic #83-Ubuntu Precision WorkStation T3500

[ 898.036374] RIP: 0010:[<ffffc90006689b82>] [<ffffc90006689b82>] 0xffffc90006689b82

[ 898.036377] RSP: 0018:ffff8802cd087d00 EFLAGS: 00010002

[ 898.036378] RAX: 0000000000000264 RBX: ffffc90006720340 RCX: 0000000000000000

[ 898.036379] RDX: ffffc90006720340 RSI: 0000000000000000 RDI: 0000000000000000

[ 898.036381] RBP: ffff8802cd087d58 R08: 000000000001ae80 R09: ffffc90006720000

[ 898.036382] R10: 0000000000040000 R11: 0000000000000000 R12: 0000000000000000

[ 898.036383] R13: 0000000000000206 R14: ffff8802fbf45810 R15: ffff8802c8d9ec00

[ 898.036384] FS: 00007fd3b77c7700(0000) GS:ffff880033300000(0000) knlGS:0000000000000000

[ 898.036386] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033

[ 898.036387] CR2: 00007fd3c9c11110 CR3: 0000000304e13000 CR4: 00000000000026e0

[ 898.036388] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000

[ 898.036389] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400

[ 898.036391] Process VirtualBox (pid: 6994, threadinfo ffff8802cd086000, task ffff880305782de0)

[ 898.036392] Stack:

[ 898.036392] ffffc900066898f2 0000000000000010 ffffffffa0de1a49 ffff8803018e2b40

[ 898.036394] <0> 0000000000009ca8 ffff8802cd087d38 00ffffff81038849 ffff8802cd087d58

[ 898.036396] <0> ffff8802fbf45810 ffff8803018f6010 ffffffffa0f5a2a0 ffff8802cd087d98

[ 898.036399] Call Trace:

[ 898.036408] [<ffffffffa0de1a49>] ? g_abExecMemory+0x166a9/0x180000 [vboxdrv]

[ 898.036414] [<ffffffffa0de2325>] g_abExecMemory+0x16f85/0x180000 [vboxdrv]

[ 898.036418] [<ffffffff810f4b9e>] ? find_get_page+0x1e/0xa0

[ 898.036425] [<ffffffffa0db75af>] ? rtR0MemAllocEx+0x7f/0x150 [vboxdrv]

[ 898.036430] [<ffffffffa0db2d8d>] supdrvIOCtl+0x14cd/0x28b0 [vboxdrv]

[ 898.036437] [<ffffffffa0db75af>] ? rtR0MemAllocEx+0x7f/0x150 [vboxdrv]

[ 898.036439] [<ffffffff810f4ea7>] ? unlock_page+0x27/0x30

[ 898.036444] [<ffffffffa0dad3b1>] VBoxDrvLinuxIOCtl_4_1_8+0x111/0x1d0 [vboxdrv]

[ 898.036447] [<ffffffff811547a2>] vfs_ioctl+0x22/0xa0

[ 898.036450] [<ffffffff815452c9>] ? thread_return+0x48/0x41f

[ 898.036452] [<ffffffff81154a51>] do_vfs_ioctl+0x81/0x380

[ 898.036454] [<ffffffff8154a508>] ? do_page_fault+0x158/0x3b0

[ 898.036456] [<ffffffff81154dd1>] sys_ioctl+0x81/0xa0

[ 898.036460] [<ffffffff810121b2>] system_call_fastpath+0x16/0x1b

[ 898.036461] Code: 00 0f 20 d8 4a 89 84 02 80 06 00 00 0f 20 e0 4a 89 84 02 88 06 00 00 48 83 e0 70 42 8b 8c 02 68 0a 00 00 23 4a 20 09 c8 0b 42 24 <0f> 22 e0 42 8b 84 02 50 0a 00 00 83 e0 04 0d 3b 00 00 80 0f 22

[ 898.036477] RIP [<ffffc90006689b82>] 0xffffc90006689b82

[ 898.036479] RSP <ffff8802cd087d00>

[ 898.036481] ---[ end trace 356b2bd055f884ae ]---

Attachments

VBox.log Download (38.9 KB) - added by tkral 2 years ago.
VBox.log.1 Download (39.2 KB) - added by tkral 2 years ago.

Change History

Changed 2 years ago by tkral

Changed 2 years ago by tkral

comment:1 Changed 2 years ago by tkral

Looks like KVM was getting in the way of VirtualBox in this case. I removed the kvm and kvm_intel modules and blacklisted them. I found the details here:

https://www.virtualbox.org/ticket/317

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Right, this is a bug in the KVM modules of older Linux kernels. In some later kernel this was fixed, that is, the VT-x root mode is not entered before a KVM VM is started.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use