VirtualBox

Ticket #1023 (closed enhancement: fixed)

Opened 6 years ago

Last modified 5 years ago

Unable to capture serial port to text file => Fixed in SVN

Reported by: aicom Owned by:
Priority: minor Component: uart
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I don't get the option to capture data sent to the COM port to a text file as I do in VMware. I use this feature a lot when debugging my OS.

Change History

comment:1 Changed 6 years ago by elhoir

same problem here

comment:2 Changed 6 years ago by frank

On linux hosts you can use an application like minicom which is able to capture the output of the serial port. Select 'host pipe' in the VM settings and select unix#path_to_the_pipe in the minicom settings. Ctrl-A L starts the minicom capture mode.

comment:3 Changed 6 years ago by elhoir

and what should be the "path" to the pipe? (its the first time i have to do it and i have no idea)

comment:4 Changed 6 years ago by frank

  • Component changed from other to uart

comment:5 follow-up: ↓ 7 Changed 5 years ago by frank

  • Summary changed from Unable to capture serial port to text file to Unable to capture serial port to text file => Fixed in SVN

Added an option to redirect the output of a serial port to a raw file on the host.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 in reply to: ↑ 5 Changed 5 years ago by nitingupta

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to frank:

Added an option to redirect the output of a serial port to a raw file on the host.

The serial output in raw file is garbled when guest logs out at a fast rate (VirtualBox 2.2.4 r47978) Guest: Fedora 10 (kernel: 2.6.29.4-75.fc10.x86_64) Host: Fedora 10 (kernel: 2.6.29.3-60.fc10.x86_64)

Grub command line: console=tty0 console=ttyS0 Also, tried: console=tty0 console=ttyS0,115200

comment:8 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

That works fine here, tested with a Fedora 11 guest on a Debian/Lenny host. If this doesn't work for you the cause is probably more a problem of the current 16450 emulation, see #1548. So lets continue to discuss there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use