VirtualBox

Ticket #10113 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Solaris 4.1.6+ shared folders causes S10 guest to panic on boot

Reported by: rasta Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description (last modified by frank) (diff)

Running Sol 10 u8 x64 guest VM on a Win7 x64 host with Core i7 980x Gulftown processor. VM has 4096 MB base ram, 4 processors selected, PAE/NX, VT-X, nested paging, 1 display with 32 MB vram, with 3d acceleration enabled.

For the past several vbox versions, I have had my boot archive become corrupted when I installed the latest Solaris additions, leading sometimes to complete virtual disk corruption. This is a MAJOR problem.

When installing 4.1.6 additions to replace 4.1.4, the disk got corrupted but I was able to fsck my way out of it.

I cannot install 4.1.8 Solaris additions no matter what. After installs corrupted my virtual disk 3 times in a row, I went back several snapshots to the state when 4.1.4 additions were installed, but still 4.1.8 install corrupted the disk. I get timeouts and read sector errors with Gen-ATA and vn_rdwr failed with error 0x5. Disk became corrupted.

Let me know if you need any further files, info, or documentation.

Attachments

VBoxSVC.log Download (6.2 KB) - added by rasta 2 years ago.
VBoxSVC.log
VBoxSVC.2.log Download (9.5 KB) - added by rasta 2 years ago.
VBox.log Download (96.6 KB) - added by rasta 2 years ago.

Change History

Changed 2 years ago by rasta

VBoxSVC.log

comment:1 Changed 2 years ago by rasta

After GA install, disk is corrupted and will not boot. svcs -xv reads at bottom (in part):

svc:/network/rpc/smserver:default (removable media management) uninitialized Reason: Restarter svc:/network/inetd:default is not running Impact: 1 dependent service is not running: svc:/system/filesystem/volfs:default

The 4.1.8 Extension Pack is installed.

comment:2 Changed 2 years ago by rasta

Solaris GA 4.1.4 introduced several shared folder fixes. I have one folder shared. Are these fixes the source of the problem?

comment:3 Changed 2 years ago by rasta

Sorry, I meant that 4.1.6 introduced the shared folder changes, not 4.1.4. I started having the problem with 4.1.6 Solaris GA.

comment:4 Changed 2 years ago by rasta

If I comment out this line from vfstab in the guest:

vm_share	-	/host_share vboxfs - yes -

and remove the shared folder from the shared folders tab in the VM guest settings, then the guest will boot with 4.1.8 GA installed, but with errors that vboxservice has failed.

comment:5 Changed 2 years ago by ramshankar

"I get timeouts and read sector errors with Gen-ATA and vn_rdwr failed with error 0x5. Disk became corrupted."

I don't see how this is related to the guest additions. Could you please upload a VBox.log for your VM where you say you encounter disk corruption?

Secondly, does the installation panic/reboot the guest spontaenously? Or does the install succeed and you encounter a guest that no longer boots?

Also, if possible, try to not use Shared folders and see if things work out. We can only start addressing this if we narrow down the possibilities. Thanks.

comment:6 Changed 2 years ago by rasta

Thank you for your reply.

"Secondly, does the installation panic/reboot the guest spontaenously? Or does the install succeed and you encounter a guest that no longer boots?"

The GA installation is normal, but the VM will not boot subsequent to install if shared folders are used.

As I wrote above, the VM will boot if shared folders are not used, but with errors that the vboxservice has failed. Shared folders have worked perfectly for over a year on my system.

I will upload another VBoxSVC.log.

Changed 2 years ago by rasta

comment:7 Changed 2 years ago by ramshankar

Please upload the VBox.log for the VM not the VBoxSVC log.

Do you unmount the sharedfolders before installing the new additions?

comment:8 Changed 2 years ago by rasta

I have never before unmounted the shared folders before installing GA, and have never had a problem. Has that become the standard procedure? If so, when?

Please see my post above about the shared folder entry in vfstab. Does the entry look correct? Should shared folders work properly with that entry? I cannot now establish shared folders using the instructions in the user manual.

For years, my shared folder has auto mounted on guest boot every time. True even with 4.1.6 GA. With 4.1.8 my shared folder is completely borked.

Changed 2 years ago by rasta

comment:9 Changed 2 years ago by rasta

If I unmount shared folders before installing 4.1.8 Solaris GA, the VM will boot, but the vboxservice fails, and my windowing is completely messed up. I have to edit xorg.conf to get my screen to resize correctly, which I haven't had to do for many vbox versions.

All production on the guest is completely down.

comment:10 Changed 2 years ago by ramshankar

I don't see any ATA errors in the host log, perhaps these were seen on the guest. Anyway, you mention data corruption, when you unmount the sharedfolders and boot the guest up again which data is corrupt? Is it files inside the shared folder?

comment:11 follow-up: ↓ 12 Changed 2 years ago by rasta

Yes, the log looked pretty clean. The errors were in the guest. It is likely that there is no actual data corruption, it's just that the guest won't boot if shared folders are used, and, even if shared folders are not used, the vboxservice isn't working properly, so my guest windowing is unstable.

Have you been able to install 4.1.8 Solaris GA into a Solaris 10 guest and have everything work normally, including shared folders?

comment:12 in reply to: ↑ 11 Changed 2 years ago by ramshankar

Replying to rasta:

Yes, the log looked pretty clean. The errors were in the guest. It is likely that there is no actual data corruption, it's just that the guest won't boot if shared folders are used, and, even if shared folders are not used, the vboxservice isn't working properly, so my guest windowing is unstable.

That's what I thought. I'll update the title of this defect as "corrupt boot archive and entire virtual disk" is a much more serious issue than this.

Have you been able to install 4.1.8 Solaris GA into a Solaris 10 guest and have everything work normally, including shared folders?

I tend to test more on S11 guests but there were a lot of changes (and some rare bug fixes) into shared folders in 4.1.8, for the moment until I test, reproduce and fix these issue I suggest going back to an older version of additions.

Thanks for the report, will try to make time to test this soon.

comment:13 Changed 2 years ago by ramshankar

  • Summary changed from Solaris 4.1.6+ guest additions corrupt boot archive and entire virtual disk to Solaris 4.1.6+ shared folders causes S10 guest to panic on boot

comment:14 Changed 2 years ago by ramshankar

Found the issue. This looks nothing more than an installer regression where we remove a driver and fail to re-add it to the boot-archive because the removal fails. Since you probably have manual entries in the vfstab perhaps S10 refuses booting because vboxfs is not loaded in memory (shouldn't) or it could be an another issue, but this is definitely one issue for VBoxService not starting up or SF not mounting because vboxguest doesn't get loaded on reboot.

Thanks for the report. The temporary solution is to run:

/opt/VirtualBoxAdditions/vboxguest.sh start
bootadm update-archive

Until the fix is in.

comment:15 Changed 2 years ago by rasta

It is EXCELLENT that you have identified the problem. I greatly appreciate your support. THANK YOU!!!!!

So do I run that command in the guest once, or every time I run the guest?

comment:16 Changed 2 years ago by rasta

YES! You nailed it.

I installed 4.1.8 Solaris GA and rebooted (shared folders are active and untouched). On boot, I get the mounting-related errors, so I enter admin mode and type those commands, and reboot again. Now everything is normal. Excellent work! YAHOO!

comment:17 Changed 2 years ago by ramshankar

Thanks for reporting, I've backported the fix to 4.1.x and 4.0.x, should be available in the next 4.1.10 release.

comment:18 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use