[vbox-dev] Configure error: kmk (variable KBUILDDIR) not found

Federico Franzoni frz.dev at gmx.com
Mon Sep 26 09:28:16 GMT 2016

Hi Frank,

Thanks for answering (and sorry for the in-thread question, I thought 
changing the subject was enough :-).

The command you suggest outputs:  "kBuild version 0.1.999 (r2504)".

Also it shows the values KBUILD_PATH and KBUILD_BIN_PATH.
I tried to set these variables and export them but nothing changed.



On 09/26/2016 08:44 AM, Frank Mehnert wrote:
> Hi Federico,
> On Freitag, 23. September 2016 13:33:29 CEST Federico Franzoni wrote:
>> Hi all,
>> I'm getting an error when trying to configure the vbox builder:
>> '
>> Checking for environment: Determined build machine: linux.amd64, target
>> machine: linux.amd64, OK.
>> Checking for kBuild:
>>     ** kmk (variable KBUILDDIR) not found!
>> '
>> I made the configure step hundreds of times and never had this problem.
>> I'm working on Fedora 23 64-bit.
>> I already configured and built vbox on this same machine, and I still
>> can, but if I try the configure step it fails as above.
>> The only thing I can guess is I accidentally removed some package, but I
>> can't figure out which one.
>> I tried searching for a solution online but I found nothing helpful.
>> Can you please help me?
> could you check if you can execute ./kBuild/bin/linux.amd64/kmk? Does
>    ./kBuild/bin/linux.amd64/kmk -v
> show the version information?
> Btw, for posting questions on mailing lists, please NEVER use an existing
> thread for posting a new question (don't use the 'Reply' button).
> Kind regards,
> Frank

More information about the vbox-dev mailing list