VirtualBox

Ticket #9918 (closed defect: invalid)

Opened 2 years ago

Last modified 15 months ago

Installing VirtualBox "deb" produces a conflict error message in Ubuntu 11.10

Reported by: Perryg Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Compiling and installing or downloading and installing produces

Error: Breaks existing package 'virtualbox-4.1' conflict: virtualbox-4.1 ( )

VirtualBox works but to update it you must first dpkg -P virtualbox-4.1

I have checked and VirtualBox was not pre-installed, not even the guest additions.

At the beginning of the install using gdebi the installer says everything is fine and no conflicts. It even states that all packages are installed and the error only pops up after the install. Of course with this error no re-install is available in gdebi.

Any ideas what needs to be done?

Attachments

11.10-install-error.png Download (39.8 KB) - added by Perryg 2 years ago.
Ubuntu1204-gdebi.png Download (76.2 KB) - added by Perryg 2 years ago.
dpkg-error-build-deb.txt Download (2.0 KB) - added by Perryg 2 years ago.
Opera-install.png Download (34.5 KB) - added by Perryg 2 years ago.

Change History

Changed 2 years ago by Perryg

comment:1 Changed 2 years ago by Perryg

Topic where others are seeing this.

 https://forums.virtualbox.org/viewtopic.php?f=7&t=45956

comment:2 Changed 2 years ago by frank

  1. Installed the Oneiric 4.1.6 package using apt-get update; apt-get install virtualbox-4.1 -- success.
  2. Then I purged the package, downloaded it and installed the package using gdebi virtualbox-4.1_4.1.6....deb as root -- success.
  3. Then I purged the package again and tried to install the package using gdebi-gtk virtualbox-4.1_4.1.6....deb. I've got a warning that this package is also available in a software channel. I chose Install package. Then I've got a strange error message:
    dpkg: error processing virtualbox-4.1_4.1.6....deb (--install):
     cannot access archive: No such file or directory
    Errors were encountered while processing:
     virtualbox-4.1_4.1.6...deb
    
  4. Same as 3., but this time I chose Download package first, then install. Installation succeeds but now I see this strange error.

My suspicion is that this has to do with the Ubuntu multiarch installer system.

comment:3 Changed 2 years ago by frank

What is the graphical representation for apt-get install ... in Oneiric? I can find only gdebi and the update manager.

comment:4 Changed 2 years ago by Perryg

That would be aptitude but they have completely trashed that package in Oneriric and no longer installed by default.

The only way I tested it was gdebi and the software center both giving what you are seeing. I know there was some work that Michael did with the Ubuntu team just before the release of 11.10 but IIRC that was just a numbering thing. I am also fairly sure that I installed in 11.10 without issue while testing was going on.

comment:5 Changed 2 years ago by Perryg

I have downloaded a different deb package (webmin.deb) to test with and it installs in the software center as it should. But I don't think it is a really good test because it does not require compiling against the kernel.

comment:6 Changed 2 years ago by Perryg

I have installed Ubuntu 12.04 and it appears that gdebi works as it is supposed to when installing a VBox deb packaged build.

The only difference is you still cannot install with their software center as it says there are upgrades available when trying to install 4.1.51 r39342, which from my thought should be impossible.

Changed 2 years ago by Perryg

comment:7 Changed 2 years ago by Perryg

Note to above. The install that works is a guest. Not metal. I know it will not run properly but all I needed to check was if it conflicted.

comment:8 Changed 2 years ago by Perryg

Frank,

After further testing I am of the opinion that this *must* be an Ubuntu 11.10 issue. I don't see this on any other distro that I test and the only thing that I am/was concerned with was the numbering between the official builds and the Ubuntu builds. Since I can install in 11.04 or 12.04 and the conflict does not occur I am of the opinion that the numbering (since it has not changed) could not be the issue.

Unless you have other thoughts, please mark this as invalid as it seems to *not* be a VirtualBox issue.

comment:9 Changed 2 years ago by frank

I would really like to close it, but OTOH I'm not aware of any other packages behaving like this.

comment:10 Changed 2 years ago by Perryg

That's true and why I came to you first. Like I said this happened just after Michael did some work (I think numbering) with the Ubuntu team. But I install my compiled DEB from SVN and the numbering is different each time and each time I have to purge the previous install. I will continue to see if I can find it but I do find it strange that it installs in 12.04 without issue. It also seems strange that it is only via a GUI install the it fails or the indicated results are not reported properly.

I will continue to investigate.

Changed 2 years ago by Perryg

comment:11 Changed 2 years ago by Perryg

Maybe this will help. (file attached)

I compiled the latest release from SVN today and tried to actually install via dpkg but without purging to begin with. It seems that Ubuntu is not happy with the name.

Conflicts: virtualbox, virtualbox-ose

Keep in mind that I can install the .run compile without issues and never need to purge when within the major release.

comment:12 Changed 2 years ago by Perryg

Note: it does install with -i

comment:13 Changed 2 years ago by Perryg

Getting closer to finding out. The error only shows in the 64-bit version (for me) 32 does not appear to have the issue so you are right as far as I can tell that the multi-arch installer must be something to look at.

Changed 2 years ago by Perryg

comment:15 Changed 2 years ago by Perryg

I still think this is really a Ubuntu issue Frank. I installed Opera amd64 deb package on Ubuntu 11.10 (on metal) and get the exact same error message using gdebi.

See Opera-install.png above

comment:16 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Thanks Perry. I think you are right.

comment:17 Changed 15 months ago by davidsarah

This is not specific to Ubuntu. It happens also for example in Linux Mint Debian Edition (64-bit).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use