VirtualBox

Ticket #9906 (closed defect: fixed)

Opened 2 years ago

Last modified 12 months ago

Update Guest Additions from 4.1.4 to 4.1.6 failed on Windows XP guest, Ubuntu 10.04 host

Reported by: rhouse Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I updated VirtualBox 4.1.4 r 74291 to 4.1.6 r74727 on my Ubuntu 10.04 system, and then started my Windows XP virtual machine. I got a message that Guest Additions needed to be updated. I followed directions and clicked on Devices > Install Guest Additions. Things did not go smoothly.

  1. This file could not be found:

c:\Program Files\sun\VirtualBox Guest Additions\VBoxGuest.sys

The problem is that "sun" is wrong. Changed "sun" to "Oracle", and the install continued.

  1. Next, this file could not be found:

C:\Program Files\Oracle\VirtualBox Guest Additions\vbcoinst.dll

I found vbcoinst.dll in c:\WINDOWS\system32, so I directed the install to use that file.

  1. I was informed that the install did not succeed. See the attached log files.

After much looking around the Internet for solutions, I tried this recommendation: Using Windows Explorer, I went to the virtual CD drive, D: on my system, and launched this program:

d:\VBoxWindowsAdditions.exe

The Guest Additions installation ran to completion, and all seems to be working okay.

Attachments

install_ui.log Download (4.0 KB) - added by rhouse 2 years ago.
install_drivers.log Download (4.2 KB) - added by rhouse 2 years ago.

Change History

Changed 2 years ago by rhouse

Changed 2 years ago by rhouse

comment:1 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use