VirtualBox

Opened 12 years ago

Closed 7 years ago

#9887 closed defect (obsolete)

Odd file permissions in files created by Host (Linux >= 2.6.38) => Fixed in SVN

Reported by: Brad Condo Owned by:
Component: shared folders Version: VirtualBox 4.1.6
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description (last modified by Frank Mehnert)

I have noticed some odd behavior in relation to shared folder files when viewed on an Ubuntu 11.10 guest and a Mac OSX 10.7.2 host in Virtualbox 4.1.6.

I am using my guest as a LAMP development server, and if I attempt to access a file via Apache running on the guest that does not exist and the subsequently create the file on the host, the file is inaccesible in the guest. A screenshot is attached of a basic ls command on the guest.

Attachments (1)

Screen Shot 2011-11-10 at 10.10.png (17.8 KB ) - added by Brad Condo 12 years ago.
Screenshot of odd file permissions

Download all attachments as: .zip

Change History (21)

by Brad Condo, 12 years ago

Screenshot of odd file permissions

comment:1 by Brad Condo, 12 years ago

I should also mention that rebooting the guest fixes the issue and the file is then accesible as expected.

comment:2 by mtsmit2, 12 years ago

I am experiencing the same issue with OSX 10.6.7 as the host OS and Ubuntu 11.10 as the guest.

It also doesn't seem to matter if the files were created by the guest or host, they can end up unreadable on the guest either way.

As mentioned above, rebooting the guest seems to fix the issue.

comment:3 by avit, 12 years ago

I wonder if Ubuntu 11.10 is a common thread here. I'm having the same problem:

I have not seen this problem on Ubuntu 10.04 VMs.

comment:4 by avit, 11 years ago

This bug is still happening:

  • Mac OS 10.7.3
  • VirtualBox 4.1.14
  • Ubuntu 12.04 server

I originally suspected Ubuntu 11.10 as a common link, but it's happening with the new version too. (Previously we were running 10.04 and didn't see the bug there.) See https://forums.virtualbox.org/viewtopic.php?f=3&t=46021 for a screenshot showing the problem.

comment:5 by pacmon, 11 years ago

I also experience this bug:

For me I'm not attempting to access via apache first. I am creating the files in the NetBeans IDE (project resides in the shared folder). I do, however, experience exactly this issue where the file is unreadable by the guest.

  • Windows 7 Host
  • VirtualBox 4.1.14 & 4.1.16
  • Fedora 16 Guest

comment:6 by Frank Mehnert, 11 years ago

Description: modified (diff)

We still need a simple scenario to reproduce this problem. So far I see only Mac OS X hosts and Windows hosts are affected, also Linux hosts?

comment:7 by Frank Mehnert, 11 years ago

Never mind. It's indeed easy to reproduce.

comment:8 by Frank Mehnert, 11 years ago

Summary: Odd file permissions in files created by HostOdd file permissions in files created by Host (Linux >= 2.6.38) => Fixed in SVN

We think we found and fixed the problem. The fix is in r41449. It affects only guest Linux kernels >= 2.6.38. Here is a test build of the 4.1.17 Guest Additions ISO image including the fix.

comment:9 by pacmon, 11 years ago

frank - I've been running the test build of 4.1.17 since you posted it. I believe you have fixed the issue. I have not yet encountered the problem since installing them.

comment:10 by Frank Mehnert, 11 years ago

Thank you pacmon for the feedback! The fix will be included in VBox 4.1.18 which is expected within some days.

comment:11 by Frank Mehnert, 11 years ago

Here is a test build for the 4.1.17 Additions containing the fix.

comment:12 by Frank Mehnert, 11 years ago

Hmm, just saw that I already posted a test build some time ago. Never mind. :)

comment:13 by Frank Mehnert, 11 years ago

Resolution: fixed
Status: newclosed

Fix in VBox 4.1.18.

comment:14 by lmc.jmshelby, 11 years ago

I have been observing this same issue happening with VBox 4.1.20 (r80170). Mac 10.6 as host, and Ubuntu oneiric as the guest. My other developers have been noticing this happening on the same VBox image with windows 7 as the host.

Has this really been proven as fixed?

comment:15 by lmc.jmshelby, 11 years ago

Resolution: fixed
Status: closedreopened

comment:16 by pemedina, 11 years ago

Same issue here running : Vbox 4.2.4 r81684, Mac 10.7.5 as host Ubuntu 11.04 (natty) as guest. ( 2.6.38-16-server )

Have to umount / mount shared folder again to see proper permissions.

comment:17 by pemedina, 11 years ago

Hi, i was wondering if there's a solution or workaround for this, because we've switched to a virtualized develoment environment and have to deal with this issue every 5 minutes.

comment:18 by Frank Mehnert, 11 years ago

Just retried with 4.2.4 Additions with an Oneiric guest (Linux 3.0) and a Linux host. What I did is

  • ls -l foo in the guest on the shared folder (foo does not exist)
  • touch foo on the host to create the file
  • ls -l foo in the guest. Now the file is there and has correct permissions.

So how can we reproduce your problem?

comment:19 by AlexCouper, 11 years ago

I am also getting this problem on a pretty regular basis.

It should be noted that:

  • not every file I create ends up in this state
  • it can happen from either the host or guest creating the files.

I'm using:

A restart of the VM fixes the issue but then new files post reboot have the potential to get the same issues.

UPDATE

Whilst writing this ticket I experienced the instance "fixing itself" without a restart. In-between the first broken ls and the last working "ls" I did the following (none of which seems drastic).

  • Loaded VirtualBox app to find the version number.
  • Ran "lsb_release -a" to get the ubuntu version.
  • Created another file and copied it.

Not sure if that helps at all...

(pretenders)alex@alex-VirtualBox:~/code/pretenders$ ls -la pretenders/mock_servers/
ls: cannot access pretenders/mock_servers/__init__.py: No such file or directory
ls: cannot access pretenders/mock_servers/http: No such file or directory
ls: cannot access pretenders/mock_servers/smtp: No such file or directory
ls: cannot access pretenders/mock_servers/ssh: No such file or directory
total 0
drwxr-xr-x 1 alex alex 204 2013-02-28 09:50 .
drwxr-xr-x 1 alex alex 578 2013-02-28 09:49 ..
?????????? ? ?    ?      ?                ? http
?????????? ? ?    ?      ?                ? __init__.py
?????????? ? ?    ?      ?                ? smtp
?????????? ? ?    ?      ?                ? ssh
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 11.10
Release:        11.10
Codename:       oneiric
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ touch fred.txt
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ ls -la
total 0
drwxr-xr-x 1 alex alex    986 2013-02-28 10:06 .
drwxrwxrwx 1 alex alex   4692 2013-02-26 10:05 ..
-rw-r--r-- 1 alex alex      0 2013-02-28 10:06 fred.txt
drwxr-xr-x 1 alex alex    578 2013-02-28 09:49 pretenders
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ cp fred.txt f.txt
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ ls
fred.txt  f.txt  pretenders
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ ls -la pretenders/mock_servers/    
total 4
drwxr-xr-x 1 alex alex  204 2013-02-28 09:50 .
drwxr-xr-x 1 alex alex  578 2013-02-28 09:49 ..
drwxr-xr-x 1 alex alex  170 2013-02-28 09:50 http
-rw-r--r-- 1 alex alex 1888 2013-02-27 23:53 __init__.py
drwxr-xr-x 1 alex alex  238 2013-02-28 09:45 smtp
drwxr-xr-x 1 alex alex  170 2013-02-28 09:46 ssh
(pretenders)alex@alex-VirtualBox:~/code/pretenders$ 
Last edited 11 years ago by AlexCouper (previous) (diff)

comment:20 by aeichner, 7 years ago

Resolution: obsolete
Status: reopenedclosed

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use