VirtualBox

Ticket #9863 (closed defect: fixed)

Opened 2 years ago

Last modified 5 weeks ago

There are no windows visible on Ubuntu 11.10 guest on a Mac OS Lion (10.7.2) with Virtualbox 4.1.6 and guest additions installed in Unity 3D.

Reported by: matthewsedam Owned by:
Priority: critical Component: GUI
Version: VirtualBox 4.1.6 Keywords: Ubuntu 11.10 Mac OS X Lion 10.7.2 no windows compiz nautilus
Cc: Guest type: Linux
Host type: Mac OS X

Description

When I installed Ubuntu 11.10 Oneiric Ocelot on Virtualbox 4.1.6 on Mac OS X 10.7.2 Lion and install guest additions, no windows will show on Unity 3D. When I click on Firefox, for example, no window is visible, but I can still maximize it and minimize it, but I cannot see it. Some workaround to this, I have found, are: to use "killall nautilus" or to login to Unity 2D and use "compiz --replace". I think the problem is with guest additions and the X.org, Nautilus, and Compiz.

Attachments

Ubuntu-2011-11-28-17-41-47.log Download (108.3 KB) - added by matthewsedam 2 years ago.
Log
VBox.log Download (112.0 KB) - added by matthewsedam 2 years ago.
Debug file from Unity

Change History

comment:1 Changed 2 years ago by aurelieng

Same here, with the same configuration. Pretty annoying.

comment:2 Changed 2 years ago by mtsmit2

Same problem for me. Host OS is OSX 10.6.7. I just ended up disabling 3d acceleration and using unity 2d for now.

comment:3 in reply to: ↑ description Changed 2 years ago by matthewsedam

What you can do is install gnome tweak tool through Unity 2D and click "Let File Manager Control Desktop" (or something like that) to disable it and Unity 3D windows work. The downside is that there will be no icons on the desktop.

comment:4 follow-up: ↓ 5 Changed 2 years ago by michael

Please attach log files from a run of the VM. In particular knowing what graphics hardware you have on the physical host system is important. And did I understand correctly that something (the Unity dock?) is visible but most things not? If so, is it something that you can capture in a screenshot?

Changed 2 years ago by matthewsedam

Log

comment:5 in reply to: ↑ 4 Changed 2 years ago by matthewsedam

Replying to michael:

Please attach log files from a run of the VM. In particular knowing what graphics hardware you have on the physical host system is important. And did I understand correctly that something (the Unity dock?) is visible but most things not? If so, is it something that you can capture in a screenshot?

Here is a hyperlink to a video that shows what is happening (I did not make it, but it is the same exact thing that is happening)  http://screencast.com/t/wZIug5RsG3fh. Also, my video card is an ATI Radeon HD 4670 with 256 mb of vram. On iMac 11,2 (mid-2010 21.5").

comment:6 follow-ups: ↓ 7 ↓ 8 Changed 2 years ago by michael

Could you try running Unity with these two environment variables set in the Ubuntu guest?

CR_DEBUG=1
CR_DEBUG_FILE=/var/tmp/VBox.log

That might provide us with more information about what is happening.

comment:7 in reply to: ↑ 6 Changed 2 years ago by matthewsedam

I added the VBox.log you asked for. Also, when I enter fullscreen, it just shows the same size box with black around it.

Changed 2 years ago by matthewsedam

Debug file from Unity

comment:8 in reply to: ↑ 6 Changed 2 years ago by matthewsedam

Replying to michael:

Could you try running Unity with these two environment variables set in the Ubuntu guest?

CR_DEBUG=1
CR_DEBUG_FILE=/var/tmp/VBox.log

That might provide us with more information about what is happening.

Any luck?

comment:9 Changed 2 years ago by misha

Unfortunately the log did not reveal the root of your problem :( We'll need to try to reproduce it here on a host with ATI graphics. Unfortunately, given the amount of work each of us currently has, this might take quite some time, but I hope we should be able to look into your issue until the end of January and will get back to you as soon as we can.

comment:10 Changed 2 years ago by bulletmark

@misha this issue is not just with ATI graphics. As I said in

 https://forums.virtualbox.org/viewtopic.php?f=8&t=45825&start=15#p209998

I have a 2011 MBA with Intel HD3000 graphics and I see this problem. Note that Unity 3D (using Compiz) does not work but gnome-shell (3D, using Mutter) does work ok. The recent VB 4.1.8 (with 4.1.8 guest additions installed) does not change this either. I wonder if anybody using Lion 10.7.2 and recent VB can run Ubuntu 11.10 Unity 3D? Given Linux is mostly Ubuntu, and Ubuntu is mostly Unity 3D, then this is a show-stopper bug for Linux hosts on Mac VB.

comment:11 Changed 2 years ago by aearenda

And it happens for me on a 2010 MacBook Pro with NVidia graphics, using Lion 10.7.2 (MacBookPro7,1). The workaround of not letting Nautilus manage the desktop works for me (see  http://ubuntuforums.org/showthread.php?p=11423998).

comment:12 Changed 2 years ago by tmandersson

Same issue for me with a 2011 MacBook Pro. (Mac Book Pro 15-inch, late 2011 with Model nr: MD318LL/A)

comment:13 Changed 2 years ago by peacockhung

Same for my 13" Mid 2009 MBP. 10.7.2 w/ nvidia 9400M

comment:14 Changed 2 years ago by matthewsedam

I just tried this out with Ubuntu 12.04 Precise Pangolin Alpha 1 and it is the exact same thing - no changes there.

comment:15 Changed 2 years ago by Matthew Sedam

Is there any news? (Changed my nickname.)

comment:16 Changed 2 years ago by Matthew Sedam

On the latest Virtualbox and the latest updates on Ubuntu 11.10, the problem goes away.

comment:17 Changed 5 weeks ago by ppostma1

This issue has resurfaced. After upgrading my virtual box to 4.3.8 I lost windows and icons in Ubuntu. At first I thought it was hanging after displaying the desktop background, but high-lights changed and things popped open as I clicked around. Most of the icons and menu's had just gone transparent.

The key sequence to pop open a terminal is ctrl + alt + t

from there, remounting and running the virtual-box guest editions /media/VBOXADDITIONS_4.3.xx_yyyy/VBoxLinuxAdditions.run

Then apt-get update and upgrade, (clean up might not hurt at all) and a reboot brought everything back to normal.

(People are being directed here after Google Searches)

comment:18 Changed 5 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use