VirtualBox

Ticket #9849 (closed defect: wontfix)

Opened 2 years ago

Last modified 2 years ago

Missing kernel-headers dependency

Reported by: alenhard Owned by:
Priority: major Component: installer
Version: VirtualBox 4.1.4 Keywords: kernel headers
Cc: Guest type: Linux
Host type: Linux

Description

Most probably the root cause was missing package linux-headers-2.6.38-12-generic-pae, so virtualbox installation has failed :

  • Trying to register the VirtualBox kernel modules using DKMS

Error! Your kernel headers for kernel 2.6.38-12-generic-pae cannot be found at /lib/modules/2.6.38-12-generic-pae/build or /lib/modules/2.6.38-12-generic-pae/source.

  • Failed, trying without DKMS
  • Recompiling VirtualBox kernel modules
  • Look at /var/log/vbox-install.log to find out what went wrong

After installation of this package, everything works fine.

Change History

comment:1 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

It's not possible to add such a dependency because the required headers have to match the currently running kernel. That even could be a self-compiled kernel. Better install DKMS as proposed in the user manual and the dependencies will be resolved automatically.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use