VirtualBox

Ticket #9841 (closed defect: duplicate)

Opened 2 years ago

Last modified 11 months ago

USB stick non-functional with more than 1 CPU enabled

Reported by: chrismurphy Owned by:
Priority: critical Component: USB
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

Summary:

When VM is set to use 2 or more CPUS, upon insertion of USB stick into host computer, guest system does not see the USB stick. No change in report by usb-devices or lsusb. dmesg does report errors, listed below. When host system is reset to use 1 CPU only, the problem does not occur, the USB stick is available.

Steps to reproduce:

  1. Configure a Fedora 16 (also tested with CentOS 6) VM to use 2 CPUs. Also installed Guest Additions from within the guest OS. (3D acceleration works, copy/paste between guest and host works.)
  1. Insert USB stick into host.
  1. In the VM's settings, Settings>Ports>USB set the following:

Enable USB Controller

Enable USB 2.0 (EHCI) Controller

Add target flash drive as a USB filter.

  1. Start the VM.
  1. Try to locate the USB stick and mount a partition.

Actual result:

USB stick (possibly other devices) is not attached to any /dev device, cannot be found. lsusb and usb-device reports the same whether stick is inserted or not. dmesg on the other hand reports:

[  556.980195] usb 1-1: new high speed USB device number 2 using ehci_hcd
[  572.123248] usb 1-1: device descriptor read/64, error -110
[  587.363281] usb 1-1: device descriptor read/64, error -110
[  587.619317] usb 1-1: new high speed USB device number 3 using ehci_hcd
[  602.763499] usb 1-1: device descriptor read/64, error -110
[  618.001222] usb 1-1: device descriptor read/64, error -110
[  618.258324] usb 1-1: new high speed USB device number 4 using ehci_hcd
[  623.300421] usb 1-1: device descriptor read/8, error -110
[  628.415623] usb 1-1: device descriptor read/8, error -110
[  628.663323] usb 1-1: new high speed USB device number 5 using ehci_hcd
[  633.685563] usb 1-1: device descriptor read/8, error -110
[  638.799324] usb 1-1: device descriptor read/8, error -110
[  638.900402] hub 1-0:1.0: unable to enumerate USB device on port 1

Expected result:

USB stick should work with any number of CPUs attached to the VM.

Regression:

When setting VM to 1 CPU, the problem does not occur. USB stick is usable. None of the above error messages is recorded.

Additional info:

Sticks tested: Kingston DT 500 16GB Lexar 2GB

Attaching vbox.log, dmesg.txt

Attachments

VBox.log Download (85.5 KB) - added by chrismurphy 2 years ago.
VBox.log
dmesg.txt Download (33.3 KB) - added by chrismurphy 2 years ago.
dmesg output

Change History

Changed 2 years ago by chrismurphy

VBox.log

Changed 2 years ago by chrismurphy

dmesg output

comment:1 Changed 2 years ago by chrismurphy

Host operating system is Mac OS X 10.6.8.

comment:2 Changed 2 years ago by chrismurphy

Guest operating system is a standard LiveCD F16beta with full updates (basically RC4). Also tested final release CentOS6 with same results.

Fedora 16 Linux f16.local 3.1.0-5.fc16.x86_64 #1 SMP Thu Oct 27 03:46:50 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

CentOS6 Linux C6virt.local 2.6.32-71.29.1.el6.x86_64 #1 SMP Mon Jun 27 19:49:27 BST 2011 x86_64 x86_64 x86_64 GNU/Linux

comment:3 Changed 2 years ago by chrismurphy

Looks like this is a duplicate of Bug 7462.

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Exactly.

comment:5 Changed 11 months ago by lkj

I don't know if it's a side effect of 4.2.13 but I can't save a machine's state. just noting it here. Host OSX 10.8.3

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use