VirtualBox

Ticket #9804 (closed defect: obsolete)

Opened 2 years ago

Last modified 2 months ago

With experimental 3d support on at least a certain platform, iTunes 10.5 (store fuctions) do not work correctly.

Reported by: Elwe Owned by:
Priority: minor Component: 3D support
Version: VirtualBox 4.1.4 Keywords: iTunes
Cc: Guest type: Windows
Host type: Linux

Description (last modified by misha) (diff)

Not sure if this is a problem with iTunes or with VirtualBox. But, after trying a lot of things (including changes to firewall, uninstallation of virus scanner, and uninstallation/reinstallion of guest additions), I know the only thing I have found that works is to not install/use the experimental 3d function in the Guest install. Specifically, the Windows logs report an error with this file:

C:\WINDOWS\system32\wined3d.dll

and Windows, when trying to use this store function to review any of the several categories (anything outside of the iTunes store--like syncing devices--seems to work fine) throws up a visual error like a program starting with a green check-mark. I cannot make out much more than that. I have to manually kill two iTunes process (one is in state not responding).

I am running Ubuntu 11.04 64bit with current patches/packages as host. I am running Windows 7 64bit with current patches as guest. I am running the 4.1.4 version of VirtualBox, with the guest additions installed. I am running latest iTunes 64bit release (10.5). Running without the experimental 3d support allows the store functions to work properly.

No relevant info seems to be stored in VBox.log, but if there is some VirtualBox specific log on the guest that would help, I can search for it. I cleared the Windows logs (lots of things fill them up, and I want to make sure I saw what was happening), so I can only give those from after the reboot after the guest additions were reinstalled without 3d support (after I tested again).

Clearly, this is not a big issue. Not sure why the iTunes store functions have to make use of anything to do with 3D, but . . .

Change History

comment:1 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions?

comment:2 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use