VirtualBox

Ticket #9801 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Virtualbox kernel modules cause heavy corruption of display

Reported by: auxsvr Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description

According to the description in  https://bugs.freedesktop.org/show_bug.cgi?id=36934#c13, the kernel modules of Virtualbox cause severe corruption of the display in Linux when using the r300g driver with a radeon AGP card. Simply loading the kernel modules in linux 3.1rc9 and various older versions is enough for heavy corruption to appear after scrolling through a PDF file in okular or using applications that load large textures. Unloading the kernel modules and restarting Xorg makes the corruption disappear, and prevents it from reappearing.

This has been occurring for at least a year with various kernel-virtualbox version combinations.

Attachments

dmesg.txt Download (59.1 KB) - added by auxsvr 2 years ago.
output of dmesg

Change History

comment:1 Changed 2 years ago by frank

Thanks for this information. Which version of VirtualBox is that and could you attach the output of 'dmesg' from your host when the kernel modules were loaded?

comment:2 Changed 2 years ago by frank

Oh, and if you could do an additional test: Do you experience the same corruption if you keep the VBox modules loaded but only unload the vboxpci module? Just a wild guess...

Changed 2 years ago by auxsvr

output of dmesg

comment:3 Changed 2 years ago by auxsvr

I forgot to load the module before I posted dmesg before; here's the output when vboxdrv is loaded:

vboxdrv: Found 1 processor cores.
vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
vboxdrv: Successfully loaded version 4.1.4 (interface 0x00190000).

This is VirtualBox-4.1-4.1.4_74291_openSUSE114-1.

comment:4 Changed 2 years ago by auxsvr

A correction to the original report: if the corruption occurs, removing the Virtualbox kernel modules and restarting X does not prevent it from occurring again. Also, loading vboxdrv only does not trigger the corruption.

One more thing: perhaps the VBox kernel modules are not the cause for the corruption, but they do make it much worse, rendering X useless. Minor and transient corruption does appear quite seldom even without any virtualbox kernel module loaded, when large textures are loaded.

comment:5 Changed 2 years ago by frank

Thanks for the additional information. To summarize:

  1. If you load all VirtualBox host kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) and even don't start the VirtualBox GUI then you experience a display corruption -- not necessarily a kernel memory corruption, right? That is, the display is corrupted but apart from that your host is as stable as it was before, is that correct?
  2. You saw this display corruption with older Linux kernels as well (I assume you also tested non-rc kernels).
  3. You even see some display corruption without any VirtualBox kernel module loaded.
  4. It seems that the vboxdrv module itself is not guilty because if you load only this module, then you don't experience any additional corruption in comparison with no VirtualBox modules loaded, right?

If this is really the case (especially point 4), could you try to isolate the guilty module even more by manually loading the vboxdrv module, check if the display corruptions happen, then load the vboxnetflt module, check again, then load the vboxnetadp module, check again and finally load the vboxpci module. This would be very helpful. Thanks in advance.

Did you experience this display corruption with older VirtualBox release as well (did you test some 4.0.x or 3.x versions before)?

comment:6 Changed 2 years ago by auxsvr

Virtualbox is not at fault, I'm sorry for wasting your time. It takes some effort to reproduce this, and it just occurred again without any virtualbox kernel module loaded.

comment:7 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for that information!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use