VirtualBox

Ticket #9719 (closed defect: fixed)

Opened 3 years ago

Last modified 14 months ago

"Error splicing file: Protocol error" when copying from vbox shared folder into ubuntu guest

Reported by: cricel472 Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 4.1.4 Keywords: copying, protocol error, shared folder
Cc: Guest type: Linux
Host type: Windows

Description (last modified by michael) (diff)

Per this forum thread:  https://forums.virtualbox.org/viewtopic.php?f=6&t=43495

I cannot copy files out of a shared folder onto my guest OS's drive using the gui (Nautilus file manager in Ubuntu 10.04 32 Desktop).

When I do, I get a gui popup of:

Error while copying "..."
There was an error copying the file into ...
Error splicing file: Protocol error

And the file in question has usually been created with a size of zero in the desired final location, but sometimes has never been created at all.

It does work to drag and drop copy into the shared folder from the guest OS's drive, and it works to copy in both directions from the command line.

I am using Windows 7 64 host with Ubuntu 10.04 32 Desktop guest.

This entire setup (same host, same guest virtual machine, same shared folder, same everything) was working completely fine until I upgraded to 4.1.4 (from 4.1.2 and 4.0.* before it).

I do not use auto-mount, I have a line in my /etc/rc.local to mount the shared folder.

As someone else in the aforementioned thread points out, this looks to be an issue with 4.1.4's guest additions, since it only showed up after installing 4.1.4's GA.

Attachments

kubuntu_v5-2011-10-08-10-52-52.log Download (94.7 KB) - added by mike2712 3 years ago.
thunar.log Download (107.3 KB) - added by daredevil200 2 years ago.
new log file

Change History

comment:1 Changed 3 years ago by Perryg

Adding comment to follow this thread.

Changed 3 years ago by mike2712

comment:2 Changed 3 years ago by mike2712

I add the following information because my experience is similar but not quite identical to that reported above.

Win 7 host, kubuntu 11.04 (natty) guest.

Shared folder has full access permissions on host and guest. The shared folder (C:\vbox_shared on Win 7 host) is mounted on /vbox_shared from /etc/fstab. The relevant line therein is:

vbox_shared /vbox_shared vboxsf defaults 0 0

Could copy files to and from the shared folder with VirtualBox 4.0.12 and every earlier version, by drag and drop in Dolphin file manager. Following upgrade from 4.0.12 to 4.1.0, 4.1.2 or 4.1.4 with installation of the appropriate extension pack and guest additions, can copy files into sf but not out using Dolphin, Konqueror or Krusader: the error message is "Cannot copy file from /vbox_shared/filename to /destination directory/filename (Errno: 71)"

Errno 71 is a protocol error.

I have tried additional filemanagers thunar and pcmanfm; these give the "Error splicing file..." protocol error reported above.

I tried commenting-out the line in /etc/fstab, adding the user to the vboxsf group and setting the share to mount automatically; this did not solve the problem. Mounting from /etc/rc.local does not solve the problem. I also tried deleting/recreating the sf.

If it helps: (a) The shared folder is mounted successfully either from /etc/fstab or from /etc/rc.local, because I can see the contents in the file managers. (b) The copy function was fine following upgrade UNTIL I installed the 4.1.4 guest additions (i.e. I initially upgraded to 4.1.4 but left the old 4.0.12 ga installed). The same occurred with 4.1.0 and 4.1.2. (c) I can confirm that the cp command in a terminal window works fine. (d) There is no problem in a VM with a Debian Lenny guest. Perryg wrote that there was no problem with Ubuntu, although the report above refers to Ubuntu 10.04: should this be kubuntu (the difference is the use of KDE versus Gnome)? (e) The same problem occurs with Debian Squeeze as host OS, kubuntu 11.04 as guest.

It therefore seems that there is a change in the 4.1.x guest additions that is incompatible with kubuntu 11.04 but does not affect Debian and possibly Ubuntu.

I attach the VBox.log.

comment:3 Changed 3 years ago by michael

Unable to reproduce this with an Ubuntu 11.10 host, so possibly Windows host-specific.

comment:4 Changed 3 years ago by Perryg

I think I remember having an issue along this line one time and traced it down to an upgrade problem. If memory serves me what I did is completely remove the guest additions. I then made sure that I removed my guests login name from the guests vboxsf group (used for auto-share) since I had also tested that.

Rebooted the guest and installed the latest guest additions and did not have a splicing error again.

However I find it necessary with Ubuntu 10.* to also use the option switch to add rw and gid,uid to the mount statement.

Worth a try!

comment:5 Changed 3 years ago by Perryg

I did some more research since this was really bothering me and come to find out this more than likely is an Ubuntu 10.04 issue. If the file is large enough this even happens on metal. I tested a 2GB transfer and it dies out at around 250MB. Tried with and without host IO cache on a 10.04 guest and it makes not difference, still fails with splicing error. I am going to setup an IDE test and see if sata has anything to do with it.

 http://ubuntuforums.org/showthread.php?t=1500384

Smaller files did not have this issue with my tests.

comment:6 Changed 3 years ago by mike2712

Some comments on the above. (a) The problem is not Windows host-specific since it also occurs on a Debian Squeeze host. (b) Switching from sata to IDE made no difference. (c) I removed the 4.1.4 guest additions, removed login name from vboxsf group (see Perryg, above); RESTART FAILED (booting started, but stopped with error "init: udev-fallback-graphics main process (605) terminated with status 1"). Had to re-install the .vdi from a safeguard. This worries me for future updates of VirtualBox, since installing the new guest additions will remove the 4.1.4 ones and may cause the same problem. This should be considered to be a major issue.

Some new facts:

(a) My .vdi is on an Ext4 filesystem. (b) The kernel is 2.6.38-11; the same problem occurred with 2.6.38-10, I do not know for earlier versions.

Could the filesystem or kernel be causing the problem?

comment:7 Changed 2 years ago by cricel472

To be clear, I am using base ubuntu 10.04, not kubuntu, so it does affect that. The files I am copying are of all kinds, but none in my tests so far have been of larger than a few megabytes, many are just a few bytes, added just to test this.

While I grant that this might be a problem with nautilus, the fact that others above have had problems with so many other file managers, and *especially* the fact that I only upgraded the guest additions, nothing else in my guest OS (or host for that matter), leads me to very strongly still suspect the guest additions as the culprit here.

The issue might be a GA upgrade issue, I will try rebuilding my setup from scratch with the same 10.04 image but using the latest virtualbox and see if that works, for comparison.

Thanks.

comment:8 Changed 2 years ago by cricel472

I just experienced this problem with a brand new virtualbox, hd, everything using same host (win7 64) now with a shiney new Xubuntu 11.10 32bit. Same shared folder as well. No other virtualboxes open at the same time, in case multiple shares would conflict. No upgrade of existing GA or anything since the 4.1.4 GA was fresh on the OS.

comment:9 Changed 2 years ago by the729

I have the same problem.

And I guess #9952 is the same issue.

host MacOSX 10.6.8 \ guest Ubuntu kernel 2.6.32-34 \ VBox 4.1.6 r74713

comment:10 Changed 2 years ago by DaKo

I have the same problem either.

I first thought that it has to to with Ubuntu 11.10 because it worked when I used Ubuntu 10.04 (and the then current version of VirtualBox) earlier this year, but I tried a few new installations and it always shows the same problem. So I assume that it worked in earlier versions of the 4.0 release.

I use Windows 7 x64 as host and Ubuntu 11.10 x32 as guest. Copying from Ubuntu to Windows works, but copying from Windows to Ubuntu shows the Protocol error. I hope this will be resolved soon.

comment:11 Changed 2 years ago by thepisu

I have the same problem, with VirtualBox 4.1.6. I use Ubuntu 11.10 64 bit as host, and Xubuntu 11.10 32 bit as guest.

I have this problem only when copying using the GUI (Thunar), instead using CP command from command line works right.

comment:12 Changed 2 years ago by philippe44

Confirmed to have the issue for a Kubuntu 11.10 32 bits on a Win7 64 host. Kubuntu updated to kernel 3.0.16 and KDE 4.7.3. Create, copy & delete files on shared folders don't work from Dolphin GUI but creating a file from some other app works (eg. files from OpenOffice). SHell cp / mv / rm work fine, as well as using other apps like Midnight Commander. I suspect it is related to some temprary file and/or rights that Dolphin is trying to create / assign - just a wild guess though

comment:13 Changed 2 years ago by dstein64

Same problem here using VirtualBox 4.1.6 on Windows 7 with both Xubuntu 11.10 and Lubuntu 11.10 guests. I tried installing earlier versions of the guest additions (e.g., 4.0.14). With earlier versions, I would not always get an error message, but the file would not copy correctly. For example, it would appear as if files copied but it would only create an empty file with the correct file name.

Like others, copying from the terminal works fine. It's just the GUI file managers that have the problem.

comment:14 Changed 2 years ago by jones.79

Another hint to track down that bug (Win7 host, Ubuntu 11.04 guest):

I have exactly the same problem and as a workaround I tried a different file manager. It looks like not all GUI tools encounter the problem. GNOME Commander ( http://www.nongnu.org/gcmd/, Ubuntu Repo) works like a charm.

What is the difference between Nautilus and GNOME Commander?

comment:15 Changed 2 years ago by dstein64

I also tried GNOME Commander. I get the error when I drag shared folder files from GNOME Commander to the Xubuntu Desktop (outside the Commander window). I do not get any error when I drag shared folder files from one pane in Commander to another pane in Commander (including ~/Desktop).

jones.79, I don't know many differences between nautilus and GNOME Commander since I don't use Commander, but one difference is the default two-pane mode in Commander. Norton Commander is a program known for this style. See  http://en.wikipedia.org/wiki/Orthodox_file_manager#Orthodox_file_managers for more details.

comment:16 Changed 2 years ago by jones.79

I can confirm that dragging folders/files from GNOME Commander to Nautilus does NOT work. There is an error message popping up: Operation not supported.

About the difference between GNOME Commander and Nautilus: My question was more about the technical difference, e.g. the used interface between the filesystem and the two file managers.

comment:17 Changed 2 years ago by chrone

i can confirm this problem happens too when copying file from shared folder on host to the guest operating system (host: win 7 pro sp1 64bit, guest: ubuntu 11.04 and 11.10 32bit).

older virtualbox 4.1 and lower didn't have the problem, only current and not so latest version has this problem.

"Error splicing file: Protocol error" was the message.

copy from guest and write to host through shared folder is not a problem, only the vice versa having trouble with.

comment:18 follow-up: ↓ 22 Changed 2 years ago by thepisu

I now updated to VirtualBox 4.1.8, updated also Guest Additions, and the problem seems solved.. Anyone else can confirm this?

comment:19 Changed 2 years ago by chrone

on 4.1.8 still could not copy from host win 7 to guest ubuntu though.

comment:20 Changed 2 years ago by cybervadim

I have the same problem with host Mac OS Lion 10.7.2 and guest openSUSE 12.1 When I am trying to copy file using Krusader or Dolphin from host shared folder (mounted using mount.vboxsf in guest) to guest OS I got "Cannot copy file ... (Errno: 71)" error. When I copy from guest to host it is working OK. It is working OK also when I am using command line commands cp, mv.

I tried VBox 4.1.8 with GuestAdditions 4.1.8 and Oracle VBox Extension pack 4.1.8 installed.

comment:21 Changed 2 years ago by cybervadim

additional note: Mac OS Lion 10.7.2 is 64bit, openSUSE 12.1 is 32bit. Maybe this is relevant.

comment:22 in reply to: ↑ 18 Changed 2 years ago by thepisu

Replying to thepisu:

I now updated to VirtualBox 4.1.8, updated also Guest Additions, and the problem seems solved.. Anyone else can confirm this?

Ops... I have again the same error. I don't know why was working yesterday. So the update 4.1.8 was not useful. Sorry!

comment:23 Changed 2 years ago by michael

You might want to give this pre-release 4.1 Additions build (usual disclaimer applies) a try:

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r75555.iso

comment:24 Changed 2 years ago by mike2712

Thank you - it works fine (for other readers, note that it is pre-release 4.1.9). Congratulations to the dev team for solving this problem.

comment:25 Changed 2 years ago by cybervadim

VBoxGuestAdditions-r75555.iso is working for host Mac OS Lion 10.7.2 and guest openSUSE 12.1 too. Thanks. I will check 4.1.9 too when it is available.

comment:26 Changed 2 years ago by michael

  • Summary changed from "Error splicing file: Protocol error" when copying from vbox shared folder into ubuntu guest to "Error splicing file: Protocol error" when copying from vbox shared folder into ubuntu guest -> fixed as of Jan 5 2012

comment:27 Changed 2 years ago by thepisu

Not solved for me with VBoxGuestAdditions-r75555.iso... It works when I restart the guest machine, but after some time the problem is back again.

comment:28 Changed 2 years ago by michael

  • Summary changed from "Error splicing file: Protocol error" when copying from vbox shared folder into ubuntu guest -> fixed as of Jan 5 2012 to "Error splicing file: Protocol error" when copying from vbox shared folder into ubuntu guest

comment:29 Changed 2 years ago by michael

Can you work with strace to find out exactly what is failing and try to produce a simple, console-only test case to reproduce it? Thanks.

comment:30 Changed 2 years ago by thepisu

I don't know how to exactly use strace.. I tried "strace thunar" (thunar if my file manager in XFCE) but it logs only on application launch. And I don't know how to reproduce the problem with command line, if I use "cp" command or something similar, the copy works well. The problem is only with graphical file manager.

I also tried this: strace thunar --daemon

With this parameter it continue logging, but when trying to copy file, and receiving "Error splicing file", not logs are written.

comment:31 Changed 2 years ago by michael

  • Description modified (diff)
$ strace -f -o thunar.log thunar

would log every system call made by thunar, following forks (so you wouldn't need the --daemon flag) and putting the log data into the file "thunar.log". You would want to search for "EPROTO" in the log output. As I said though, I would love a simple, command-line only recipe for reproducing this.

Changed 2 years ago by daredevil200

new log file

comment:32 Changed 2 years ago by daredevil200

I just have the same problem on Window as Host / Virtual Box / xUbuntu 11.10.

I uploaded the log file requested.

comment:33 Changed 16 months ago by thepisu

After weeks of usage with VirtualBox 4.2, I can say it's finally solved for me.

comment:34 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback. Let's close this ticket then.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use