VirtualBox

Ticket #9537 (new defect)

Opened 3 years ago

Last modified 10 months ago

AES-NI (AES New Instructions) from SandyBridge CPUs are not forwarded to Guest

Reported by: USBProb Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords: AES-NI AES New Instructions
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Problem is there  http://forums.virtualbox.org/viewtopic.php?f=7&t=42951 documentated. Host (Intel i5 2500K) shows in CPU-Z AES support, in Guest there is now AES-NI support. I think that can be solved with a (V-BOX)BIOS-Update, had a notebook with the same problem, BIOS update and then AES-NI worked. Perphaps these links help  http://communities.intel.com/thread/23583 and  http://forum.notebookreview.com/windows-os-software/582628-aes-ni-support-truecrypt-sandy-bridge-problem.html

Change History

comment:1 Changed 13 months ago by hnapel

This problem still exists on Virtualbox 4.2.8 , I'm using a guest OS that supports AES-NI (OEL5) but it's not passed to the guest, the following C program will tell you if AES instructions work:

$ cat aes.c #include <stdio.h> #define cpuid(level, a, b, c, d) \

asm("xchg{l}\t{%%}ebx, %1\n\t" \

"cpuid\n\t" \ "xchg{l}\t{%%}ebx, %1\n\t" \ : "=a" (a), "=r" (b), "=c" (c), "=d" (d) \ : "0" (level))

int main (int argc, char argv) {

unsigned int eax, ebx, ecx, edx; cpuid(1, eax, ebx, ecx, edx); if (ecx & (1<<25))

printf("aes\n");

else

printf("no aes\n");

return 0;

}

$ ls aes.c [oracle@oel5vmware c]$ make aes cc aes.c -o aes [oracle@oel5vmware c]$ ./aes aes

This is on vmware 9 where it works, however on vbox it doesn't:

[oracle@oel64 ~]$ vi aes.c [oracle@oel64 ~]$ make aes cc aes.c -o aes [oracle@oel64 ~]$ ./aes no aes [oracle@oel64 ~]$ uname -a Linux oel64.fritz.box 2.6.32-300.32.1.el5uek #1 SMP Fri Jul 20 00:51:02 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux [oracle@oel64 ~]$

comment:2 Changed 10 months ago by TrevorPH

Issue exists on linux hosts with 4.2.12 (have not tried 4.2.14 yet but nothing is listed in the Changelog).

Has anyone from Innotek/Sun/Oracle/Virtualbox even opened this bug?

comment:3 Changed 10 months ago by frank

  • Description modified (diff)

The bug is already open, so no need to open it again. In short term there will be no support for AES-NI instructions in VirtualBox. That might be different in medium term.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use