VirtualBox

Ticket #951 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Sleeping threads/processes

Reported by: teddy Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: Thread Process Task
Cc: Guest type: other
Host type: other

Description

Say I want to compile some software, it will start compiling for a while and then it will stop at some random point in the compile session. To get it working again I have to move the compile window or in some way interact with the thread that is running the compile. It looks like it "forget" the thread or something. This was just an example, it will almost always do this on some thread that work over time, like the windows installation, copy process, etc, etc.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by frank

Which host system is this (OS, CPU)?

comment:2 in reply to: ↑ 1 Changed 6 years ago by teddy

Replying to frank:

Which host system is this (OS, CPU)?

Oh, sorry forgot....

This is on Linux (Ubuntu 7.10), and the processor is (cat /proc/cpuinfo) AMD Athlon(tm) 64 X2 Dual Core Processor 3800+. Running in 32bit mode. The processor has got the AMD-V flag, the hardware virtualizing is enabled.

Even

comment:3 Changed 6 years ago by frank

Try to boot your host kernel with the option "nohz=off" (press ESC during Ubuntu boot and append that option to the kernel command line). To make sure you did it right, check /proc/cmdline if this option is contained there. Then start VirtualBox. Does that make any difference?

comment:4 Changed 6 years ago by teddy

Looks like I am not able to reproduce the error. I had to reboot my linux because I had a hardware issue. After the reboot Virtualbox has been working flawlessly.

I have this geeky trust in my linux and that _NOTHING_ can go wrong with with it. This time it looks like it _WAS_ something with the kernel/xorg/kde/etc. Looks like I have to lower my expectations of my Linux distro and start to look at it like a peace of software ;). Sorry for the inconvenience.

Even

comment:5 Changed 6 years ago by xwisdom

I got a similar behavior when using xcopy to copy files in a command line windows on windows XP sp2. After a time the copying process would pause and it's not until I open up the my computer window before it resumes.

comment:6 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

These problems should be gone with VirtualBox 1.6.x.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use