VirtualBox

Ticket #9459 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Linux guests crash with Call Trace - Intel DQ67SW mainboard

Reported by: mcw Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords: Call Trace
Cc: Guest type: Linux
Host type: other

Description

Hello,

I just experienced Call Traces nearly every time I wanted to boot (different) Linux(es) as guest on my Windows 7 Pro SP1 x86_64 host.

My hardware: Intel DQ67SWB3 mainboard (BIOS revision 53), Intel Core i7 2600 (non-K, non-S) CPU.

Sporadically, I could boot into the guests, but mostly they crashed, no matter wether these were 32 or 64 bit guests. Disabling I/O-APIC in the VM configuration, nor "noapic", "nolapic" etc. in the guest worked... The only solution that worked for me was: either to allocate more than 1 CPU to the guest or to disable VT-x support (which only works for 32 bit VMs).

Ubuntu 10.04 (server) x86_64 as host seemd to work fine, but I don't know if that was just a coincidence or maybe Linux is more "fault-tolerant(...)".

The "real" solution for this problem was different and simple: Updating the BIOS revision to 54 that Intel just released a few days ago ( http://downloadmirror.intel.com/20333/eng/SW_0054_ReleaseNotes.pdf -> MWAIT fix). Since I upgraded my BIOS, no Call Traces occured anymore...

I also attached the logs where you can see the inconsistency of the MONITOR/MWAIT flag.

Thanks a lot for the help and support of the friendly guys on IRC (especially MichalM).

Attachments

broken-VBox.log Download (78.3 KB) - added by mcw 3 years ago.

Change History

Changed 3 years ago by mcw

comment:1 Changed 3 years ago by michaln

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #9460.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use