VirtualBox

Ticket #9392 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Cannot clone if any snapshot has an ISO assigned to CD/DVD

Reported by: dalepres Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.1.0 Keywords: clone iso snapshot
Cc: Guest type: Windows
Host type: Windows

Description

If you have an ISO attached to the CD/DVD drive of a VirtualBox VM, in any snapshot - even if detached in the current state - you cannot clone. The clone fails. If you have a lot of snapshots, having to load each and every snapshot and remove the ISO does not make sense.

This is something that should not be even tested in cloning. It should only be tested at run time when the ISO is loaded in a running VM. If the VM cannot get an exclusive lock on the ISO, report the condition and continue to load the VM without an ISO attached.

Equally bad as the "any snapshot" condition of this bug, if this does have to be tested in cloning (which it should not be) it should be tested before the VDI file is copied. It makes no sense to spend 20 to 30 minutes copying a large VDI file and then fail for something that could have been tested before copying the VDI file.

Attachments

VBoxSVC.log Download (4.8 KB) - added by dalepres 3 years ago.
Log file showing error on cloning.

Change History

Changed 3 years ago by dalepres

Log file showing error on cloning.

comment:1 Changed 3 years ago by dalepres

I don't see a way to change the priority of this bug but I believe it should now be higher than major. Cloning in 4.1.0 appears to be impossible. No VM I have has VBoxGuestAdditions.iso connected to current state or to any snapshot (I've even deleted all snapshots) yet cloning still gives the error that it cannot register image (path to)VBoxGuestAdditions.iso because it exists. A virtualization tool without cloning is not usable.

I have spent days working on converting my VMWare VMs to VirtualBox because VMWare Server has not been supported for years. Until I can clone, I have to stop using VirtualBox and stay with VMWare Server.

Thanks.

Dale

comment:2 Changed 3 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9303.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use