VirtualBox

Ticket #9372 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

Specific USB device can't be passed to any guest - only Linux host

Reported by: UbuntuInAustria Owned by:
Priority: major Component: USB
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I have a specific USB device that can't be passed to my guest, if I run VirtualBox 4.1.0 on a Linux host. If I run VirtualBox 4.1.0 on a Windows host - no problems.

Here is what happens, when I plug the specific device in: dmesg | tail -n5

[   27.014827] vmnet1: no IPv6 routers present
[   44.009142] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
[  154.552933] usb 1-1.5: new full speed USB device using ehci_hcd and address 3
[  154.647133] usb 1-1.5: configuration #1 chosen from 1 choice
[  154.648777] generic-usb 0003:0000:0000.0004: hiddev96,hidraw3: USB HID v1.00 Device [BioSign STRESSBALL] on usb-0000:00:1a.0-1.5/input0

And lsusb:

Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 062a:0001 Creative Labs Notebook Optical Mouse
Bus 002 Device 003: ID 045e:00dd Microsoft Corp. 
Bus 002 Device 002: ID 8087:0020  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0000:0000  <---- here we have the device
Bus 001 Device 002: ID 8087:0020  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Maybe the problems is because of the strange id of the USB device.

VirtualBox only finds my USB mouse and my USB keyboard: sudo vboxmanage list usbhost

Host USB Devices:

UUID:               f5f2378d-3c32-4707-be27-c968ad77f068
VendorId:           0x045e (045E)
ProductId:          0x00dd (00DD)
Revision:           1.115 (01115)
Manufacturer:       Microsoft
Product:            Comfort Curve Keyboard 2000
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5//device:/dev/vboxusb/002/003
Current State:      Busy

UUID:               d342948d-dbdb-4695-b190-9c44a531bb2d
VendorId:           0x062a (062A)
ProductId:          0x0001 (0001)
Revision:           0.0 (0000)
Address:            sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6//device:/dev/vboxusb/002/004
Current State:      Busy

Other USB devices are working, they show up and I can work with them in the VM. I only had to add my user to the group vboxusers. This specific device is only working on a Windows host.

Attachments

Log.tar.gz Download (58.4 KB) - added by UbuntuInAustria 3 years ago.

Change History

Changed 3 years ago by UbuntuInAustria

comment:1 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use