VirtualBox

Ticket #936 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

[PATCH] Fix compilation with gcc 4.3

Reported by: cartman Owned by: frank
Priority: major Component: host support
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Patch taken from OpenSuse.

Attachments

gcc-4.3.patch Download (3.0 KB) - added by cartman 6 years ago.
use-o3-to-workaround-gcc-ice.diff Download (845 bytes) - added by dmueller 6 years ago.
patch for spill error

Change History

Changed 6 years ago by cartman

comment:1 Changed 6 years ago by frank

  • Owner set to frank
  • Status changed from new to assigned

We have fixed some of these problems ourself, some are still to do. Note that we don't support gcc-4.3 yet. That is VBox compiled with this compiler is not supposed to work well. We will not support gcc-4.3 before it is finally released. Currently I'm observing problems in the recompiler.

comment:2 Changed 6 years ago by cartman

If you find any problems on the compiler side please report them, GCC 4.3 will soon go into regression-only mode and be released as stable from there.

comment:3 Changed 6 years ago by frank

The problem we have with gcc-4.3 is most probably the hacky way the QEmu stuff (the recompiler/ directory was originally taken from Qemu and extended) uses the assembler output of gcc. For instance, gcc-4.0 is known to not work as well. This is less a problem of gcc than of using the generated code.

comment:4 Changed 6 years ago by cartman

Ah qemu problems I see, upstream qemu still doesn't support gcc4 let alone gcc 4.3.

comment:5 Changed 6 years ago by dmueller

changing -O3 seems to fix the helper.c compiler ICE with gcc 4.3, see gcc.gnu.org/bugzilla/show_bug.cgi?id=35135

Changed 6 years ago by dmueller

patch for spill error

comment:6 Changed 6 years ago by frank

Thanks for this update!

comment:7 Changed 6 years ago by frank

Note that we fixed the source a little bit different. But the file op.c still requires gcc <= 4.2. The configure script detects this correctly and asks for a compatibility compiler.

comment:8 Changed 6 years ago by frank

  • Host type changed from other to Linux
  • Component changed from other to host support

comment:9 Changed 5 years ago by frank

  • Status changed from assigned to closed
  • Resolution set to fixed

Finally obsolete since release 2.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use