VirtualBox

Ticket #9320 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

PutMouseEventAbsolute function produces a click with -2 offset on each coordinate -> duplicate of #9321

Reported by: Kortex Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.0 Keywords: IMouse, PutMouseEventAbsolute
Cc: Guest type: other
Host type: other

Description

I am using VirtualBox SDK to move/click mouse on guest from app running on host through IMouse interface. I've noticed that when I call PutMouseEventAbsolute(x, y, 0, 0, 1) the real click happens at (x-2,y-2) position.

GA are installed, but Mouse Integration is disabled for the guest.

I have created .NET wrapper for VirtualBox.exe with tlbimp tool.

My program looks like this:

/

VirtualBoxClass vbc = new VirtualBoxClass(); IMachine vm = vbc.FindMachine("w7");

SessionClass s = new SessionClass();

vm.LockMachine(s, LockType.LockType_Shared);

s.Console.Mouse.PutMouseEventAbsolute(100, 100, 0, 0, 1);

/

the click happens at (98,98)

Change History

comment:1 Changed 3 years ago by Kortex

this ticket duplicates ticket #9321, please ignore this one, since #9321 has .log file attached

comment:2 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from PutMouseEventAbsolute function produces a click with -2 offset on each coordinate to PutMouseEventAbsolute function produces a click with -2 offset on each coordinate -> duplicate of #9321
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use