VirtualBox

Ticket #9315 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

File not being truncated on shared folder - WinXP 32 SP3 guest on WinXP 32 SP3 host, VBox 4.1.0+Guest Additions 4.1.0

Reported by: DfDf Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

When a file on shared folder (for example - even a plain text) is being edited in Far ( http://www.farmanager.com) and when tail of file (for ex. - 4-5 last lines) is being deleted, after that file is saved - the tail remains in file as it was not deleted.

Steps to reproduce:

  1. Map a shared folder with full access and automount in guest OS.
  2. Put a short (about 1K) plain text file to shared folder.
  3. Download far manager from  http://www.farmanager.com (open source).
  4. Install FAR in guest OS.
  5. Change to shared folder in guest OS via FAR. (Alt-F2)
  6. Press F4 (edit) on file from step 2.
  7. Remove several last lines (4-5) from the end of file (in any way - for ex. by Ctrl-Y).
  8. Press F2 to save changes (or ESC, and than confirm save).
  9. Quit editor by ESC.
  10. Open file in host OS (or even again in guest OS) in notepad. Observe the BUG - deleted lines are still present in the file AND file size IS NOT CHANGED.

FAR uses this steps to write to file:

  1. File is being read to memory, than closed.
  2. User edit the file and presses F2 to write to file.
  3. File is being reopened with write access.
  4. File is truncated to 0 bytes length.
  5. Memory is being written back to file.

At this point if file resides on shared folder and edited from guest OS - the BUG arrives.

Change History

comment:1 Changed 3 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for the report. The problem is fixed in:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r73157.iso

Please install the new additions.

Actually this is the same problem as of  http://www.virtualbox.org/ticket/9276

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use