VirtualBox

Ticket #927 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Fails to bring host networking down on startup error

Reported by: fjp Owned by:
Priority: major Component: VM control
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I had been using a "host pipe" serial port, which I create using an external command (socat) before booting the VM. Unfortunately, the command exits and the socket file is deleted when I shut down a VM.

If the socket file is missing when the VM is booted, this results in the following error:

Serial device 0 cannot attach to char driver
.
VBox status code: -102 (VERR_FILE_NOT_FOUND).

Result Code: 0x80004005
Component: Console
Interface: IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

And the VM fails to start. I disabled the serial port and then tried to start the VM again, but then got the following rather cryptic error:

Unknown error creating VM (VERR_HOSTIF_INIT_FAILED).
VBox status code: -3100 (VERR_HOSTIF_INIT_FAILED).

Result Code: 0x80004005
Component: Console
Interface: IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

Only after a lot of frustration did I discover that this was caused by the fact that my "host interface" network adapter had not been brought down after the first attempt to start the VM.

Manually running the script I use to bring the vbox0 interface down solved the problem, but that was only after I had already deleted the VM and its snapshots and created a new one :-(

Please:

  • make the error message a bit less cryptic, for example by mentioning the name of the "Setup application" that has been configured to set up the host interface
  • ensure that the host interface is brought down automatically (by running the "Terminate application") when there are unrelated problems starting a VM after the host interface has already been brought up

The first error message could also be improved by explicitly mentioning which file could not be found.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to VM control

comment:2 Changed 4 years ago by Technologov

Host networking got a total rewrite in VBox 2.1.

Please Close this bug.

-Technologov

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use