VirtualBox

Opened 13 years ago

Closed 10 years ago

#9262 closed defect (fixed)

Aero still does not work well

Reported by: komanek Owned by:
Component: WDDM Version: VirtualBox 4.1.0
Keywords: Cc:
Guest type: Windows Host type: Linux

Description (last modified by misha)

Hello,

I upgraded to VB 4.1 (on Fedora 14 host box) and installed new guest additions in my Windows 7 SP1 (64-bit) guest OS (the new video driver enabled). Although I can switch to an aero theme, there are not other things working:

  • no transparency
  • no window thumbnails
  • win+tab key combination is not working
  • windows user experience score calculation ends up with an error

Attachments (5)

VBox.log.3 (66.3 KB ) - added by komanek 13 years ago.
logfile for half-working areo
VBox.log.2 (60.6 KB ) - added by komanek 13 years ago.
crashing guest soon after logging the user into its desktop
VBox.log.1 (60.6 KB ) - added by komanek 13 years ago.
another crash
VBox.log (70.4 KB ) - added by komanek 13 years ago.
working now with an old-style 3d driver (works without crashes with exception of MS PowerPoint 2010)
winsat.log (56.4 KB ) - added by komanek 12 years ago.
winsat.log from W7 SP1 64bit on Fedora 15 64bit host

Download all attachments as: .zip

Change History (16)

comment:1 by misha, 13 years ago

Based on your description it seems like Aero theme is not enabled for you at all.
Aero is not enabled by default currently instead you should enable it explicitly via Control Panel\Appearance and Personalization\Personalization (accessible through desktop context menu as well).
Do you see Aero themes listed there?
Is Aero theme marked enabled for you?
Please attach a Log file for your VM session in case you fail to enable Aero theme.

comment:2 by komanek, 13 years ago

Yes, I can see the aero themes and choose them. It changes the desktop background, some color, but does not switch on other features.

I think it is caused by the windows experience index, wich is still of value 1.0 only - refreshing this score does not work because it ends up with an error, but nothing specific is displayed, only the general confirmation window appears, stating that the hardware capability testing did not complete.

I also experienced a few guest OS crashes, so I am reverting to the classical display drivers for some time and will try it again with 4.1.2 or so.

comment:3 by misha, 13 years ago

Did you increase the guest VRAM to at least 128M?
Please attach a VM session log file here so we can investigate the problem.

by komanek, 13 years ago

Attachment: VBox.log.3 added

logfile for half-working areo

by komanek, 13 years ago

Attachment: VBox.log.2 added

crashing guest soon after logging the user into its desktop

by komanek, 13 years ago

Attachment: VBox.log.1 added

another crash

by komanek, 13 years ago

Attachment: VBox.log added

working now with an old-style 3d driver (works without crashes with exception of MS PowerPoint 2010)

comment:4 by komanek, 13 years ago

I attached my log files. Guest VRAM is at 256M.

Thank you in advance for the analysis.

comment:5 by Poul Bak, 13 years ago

In fullscreen, I get the same behaviour, even lock ups, for instance: Right click, 'Run as administrator', the UAC prompt will mess things up.

comment:6 by komanek, 13 years ago

still the same in VB 4.1.4, at least for me:

  • windows experience index cannot be calculated, so it is still of value 1.0
  • upgraded host to Fedora 15 with latest kernel and gnome 3 (64bit), patched my guest Win 7 SP1 (also 64bit) with all what was available through windows update, used the latest guest additions with supposedly aero-capable videodriver

Still nothing, aero does not work for me.

comment:7 by Eric McIntyre, 12 years ago

I am also getting the same behavior. No crashes, but the Windows Experience Index test completes with unspecified errors, so Aero will not enable. With a previous VirtualBox version (3.2?), I was able to complete the test and get a rating.

VirtualBox 4.1.4 Host: Ubuntu 11.10 64-bit, Athlon II X3, 12 GB RAM, Nvidia GeForce 9400 GT w/ 256 MB Guest: Win 7 Pro SP1 32-bit, 2 GB RAM, 128 MB VRAM, VirtualBox Graphics Adapter (Microsoft Corporation - WDDM)

comment:8 by Andre.Ziegler, 12 years ago

post the WinSAT.log from C:\Windows\Performance\WinSAT to see what causes the Index generation failure.

by komanek, 12 years ago

Attachment: winsat.log added

winsat.log from W7 SP1 64bit on Fedora 15 64bit host

comment:9 by misha, 12 years ago

Component: 3D supportWDDM

comment:10 by komanek, 12 years ago

After some windows patches applied in last days through windowsupdate it seems to work at least partially (vbox 4.1.6 running Windows 7 64bit CZ on Fedora 15 host):

  • after windows OS startup, aero is working
  • running some system apps (e.g. control panel widgets) forces windows VM to switch off the aero features until next OS restart
  • windows experience index still can't be computed

So thank you very much for the advancement in solving this issue.

comment:11 by misha, 10 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

Could you check whether this issue is solved with VBox 4.3 amd 4.3 Additions and re-open the ticket if needed?

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use