VirtualBox

Ticket #9262 (closed defect: fixed)

Opened 3 years ago

Last modified 6 months ago

Aero still does not work well

Reported by: komanek Owned by:
Priority: major Component: WDDM
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by misha) (diff)

Hello,

I upgraded to VB 4.1 (on Fedora 14 host box) and installed new guest additions in my Windows 7 SP1 (64-bit) guest OS (the new video driver enabled). Although I can switch to an aero theme, there are not other things working:

  • no transparency
  • no window thumbnails
  • win+tab key combination is not working
  • windows user experience score calculation ends up with an error

Attachments

VBox.log.3 Download (66.3 KB) - added by komanek 3 years ago.
logfile for half-working areo
VBox.log.2 Download (60.6 KB) - added by komanek 3 years ago.
crashing guest soon after logging the user into its desktop
VBox.log.1 Download (60.6 KB) - added by komanek 3 years ago.
another crash
VBox.log Download (70.4 KB) - added by komanek 3 years ago.
working now with an old-style 3d driver (works without crashes with exception of MS PowerPoint 2010)
winsat.log Download (56.4 KB) - added by komanek 2 years ago.
winsat.log from W7 SP1 64bit on Fedora 15 64bit host

Change History

comment:1 Changed 3 years ago by misha

Based on your description it seems like Aero theme is not enabled for you at all.
Aero is not enabled by default currently instead you should enable it explicitly via Control Panel\Appearance and Personalization\Personalization (accessible through desktop context menu as well).
Do you see Aero themes listed there?
Is Aero theme marked enabled for you?
Please attach a Log file for your VM session in case you fail to enable Aero theme.

comment:2 Changed 3 years ago by komanek

Yes, I can see the aero themes and choose them. It changes the desktop background, some color, but does not switch on other features.

I think it is caused by the windows experience index, wich is still of value 1.0 only - refreshing this score does not work because it ends up with an error, but nothing specific is displayed, only the general confirmation window appears, stating that the hardware capability testing did not complete.

I also experienced a few guest OS crashes, so I am reverting to the classical display drivers for some time and will try it again with 4.1.2 or so.

comment:3 Changed 3 years ago by misha

Did you increase the guest VRAM to at least 128M?
Please attach a VM session log file here so we can investigate the problem.

Changed 3 years ago by komanek

logfile for half-working areo

Changed 3 years ago by komanek

crashing guest soon after logging the user into its desktop

Changed 3 years ago by komanek

another crash

Changed 3 years ago by komanek

working now with an old-style 3d driver (works without crashes with exception of MS PowerPoint 2010)

comment:4 Changed 3 years ago by komanek

I attached my log files. Guest VRAM is at 256M.

Thank you in advance for the analysis.

comment:5 Changed 3 years ago by poulbak

In fullscreen, I get the same behaviour, even lock ups, for instance: Right click, 'Run as administrator', the UAC prompt will mess things up.

comment:6 Changed 3 years ago by komanek

still the same in VB 4.1.4, at least for me:

  • windows experience index cannot be calculated, so it is still of value 1.0
  • upgraded host to Fedora 15 with latest kernel and gnome 3 (64bit), patched my guest Win 7 SP1 (also 64bit) with all what was available through windows update, used the latest guest additions with supposedly aero-capable videodriver

Still nothing, aero does not work for me.

comment:7 Changed 3 years ago by macdaddyaz

I am also getting the same behavior. No crashes, but the Windows Experience Index test completes with unspecified errors, so Aero will not enable. With a previous VirtualBox version (3.2?), I was able to complete the test and get a rating.

VirtualBox 4.1.4 Host: Ubuntu 11.10 64-bit, Athlon II X3, 12 GB RAM, Nvidia GeForce 9400 GT w/ 256 MB Guest: Win 7 Pro SP1 32-bit, 2 GB RAM, 128 MB VRAM, VirtualBox Graphics Adapter (Microsoft Corporation - WDDM)

comment:8 Changed 2 years ago by Andre.Ziegler

post the WinSAT.log from C:\Windows\Performance\WinSAT to see what causes the Index generation failure.

Changed 2 years ago by komanek

winsat.log from W7 SP1 64bit on Fedora 15 64bit host

comment:9 Changed 2 years ago by misha

  • Component changed from 3D support to WDDM

comment:10 Changed 2 years ago by komanek

After some windows patches applied in last days through windowsupdate it seems to work at least partially (vbox 4.1.6 running Windows 7 64bit CZ on Fedora 15 host):

  • after windows OS startup, aero is working
  • running some system apps (e.g. control panel widgets) forces windows VM to switch off the aero features until next OS restart
  • windows experience index still can't be computed

So thank you very much for the advancement in solving this issue.

comment:11 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Could you check whether this issue is solved with VBox 4.3 amd 4.3 Additions and re-open the ticket if needed?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use