VirtualBox

Ticket #919 (reopened defect)

Opened 6 years ago

Last modified 4 years ago

Unable to create a vmdk for raw drive partition (VERR_SHARING_VIOLATION) -> fixed in SVN/1.6.2

Reported by: Demon Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Using Windows XP host, I was unable to create a raw vmdk for my existing linux partition.

WinXP resides in \.\PhysicalDrive0 partition 1, and Linux resides in \.\PhysicalDrive1 partitions 1,5 (main, swap).

"VBoxManage.exe internalcommands listpartitions -rawdisk \.\PhysicalDrive1" output: Number Type StartCHS EndCHS Size (MiB) Start (Sect) 1 0x83 0 /1 /1 1023/254/63 14307 63 5 0x82 1023/254/63 1023/254/63 956 29302623 3 0x07 1023/0 /1 1023/254/63 289977 31262490

The command used to create the raw vmdk: "VBoxManage.exe internalcommands createrawvmdk -filename c:\ubuntu1.vmdk -rawdisk \.\PhysicalDrive1 -partitions 1,5"

Output:

ERROR: VMDK: could not create new partition data file 'c:\ubuntu1-pt.vmdk' Error code VERR_SHARING_VIOLATION at E:\vbox\1.5-w32-rel\src\VBox\Devices\Storag e\VmdkHDDCore.cpp(2224) in function vmdkCreateImage Error while creating the raw disk VMDK: VERR_SHARING_VIOLATION

Change History

comment:1 Changed 6 years ago by sandervl73

  • Priority changed from blocker to critical

comment:2 Changed 6 years ago by ouci

Exactly the same problem here, although I am a complete newbie with this, I had encountered exactly the same error message.

comment:3 Changed 6 years ago by ouci

Forgot to mention, I was also trying to make a vmdk to use 2 partitions, one is ext3 the other swap.

comment:4 Changed 6 years ago by grassvalley

I has the same error.

Host is windows2000server,I want to mount a ext3 partition and a swap partition.

comment:5 Changed 6 years ago by ldoubleu

I have the same problem. I upgraded to version 1.5.4 but the problem remains the same. Host is Windows XP Home.

comment:6 Changed 6 years ago by gourmet

I confirm this problem. Tried create vmdk file for Linux partitions (reiserfs and swap):

E:\Program Files\innotek VirtualBox>VBoxManage internalcommands createrawvmdk -filename F:\LIN.vmdk -rawdisk \.\PhysicalDrive0 -partitions 9,11 -register
VirtualBox Command Line Management Interface Version 1.5.6
(C) 2005-2008 innotek GmbH
All rights reserved.

ERROR: VMDK: could not create new partition data file 'c:\LIN-pt.vmdk'
Error code VERR_SHARING_VIOLATION at C:\vbox\branch\w32-1.5\src\VBox\Devices\Storage\VmdkHDDCore.cpp(2224) in function vmdkCreateImage
Error while creating the raw disk VMDK: VERR_SHARING_VIOLATION

notice about version 1.5.6 - problem persists from earlier versions

PLEASE SOLVE THIS!!'''

comment:7 Changed 6 years ago by sandervl73

  • Summary changed from Unable to create a vmdk for raw drive partition (VERR_SHARING_VIOLATION) to Unable to create a vmdk for raw drive partition (VERR_SHARING_VIOLATION) -> fixed in SVN/1.6.2

Should be fixed in 1.6.2.

comment:8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 4 years ago by tps800

With 3.1.2 this error is up again. I've tried to search for a newer ticket, but only found this one. Seems to be a regression if it had worked time before ...

comment:10 Changed 4 years ago by tps800

Here is what the command exausts:

C:\prgs\Sun\VirtualBox\VBoxManage.exe internalcommands listpartitions -rawdisk \.\PhysicalDrive0
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Error opening the raw disk: VERR_SHARING_VIOLATION

With whole disk access:

C:\prgs\Sun\VirtualBox\VBoxManage.exe internalcommands createrawvmdk -filename kiwi0.vmdk -rawdisk \.\PhysicalDrive0
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Error opening the raw disk '\.\PhysicalDrive0': VERR_SHARING_VIOLATION
The raw disk vmdk file was not created

And only partitions I would wish to have access to:

C:\prgs\Sun\VirtualBox\VBoxManage.exe internalcommands createrawvmdk -filename kiwi0.vmdk -rawdisk \.\PhysicalDrive0 -partitions 1,4
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Error opening the raw disk '\.\PhysicalDrive0': VERR_SHARING_VIOLATION
The raw disk vmdk file was not created

Maybe we could reopen this ticket?

comment:11 Changed 4 years ago by buckyball

  • Status changed from closed to reopened
  • Resolution fixed deleted

This problem still exists in VB 3.1.6

Windows XP Pro SP3

Requesting a re-open on the bug.

comment:12 Changed 4 years ago by buckyball

Got a response from the bug tracker about a change being checked in for 1.6.2 ...

We _are_ talking about a bug in the 3.x.x series, right?

I've just confirmed the problem still exists in VBox 3.2.0.

Thanks for any help you folks can provide.

comment:13 Changed 4 years ago by maxvohlken

I'm having a similar problem on Windows 7 64bit.

C:\Program Files\Sun\VirtualBox>VBoxManage.exe internalcommands listpartitions -rawdisk \.\PhysicalDrive2 Sun VirtualBox Command Line Management Interface Version 3.1.4 (C) 2005-2010 Sun Microsystems, Inc. All rights reserved.

Error opening the raw disk: VERR_SHARING_VIOLATION

I've tried both VirtualBox-3.1.4-57640-Win and VirtualBox-3.2.4-62467-Win.

I also get the same error trying to run createrawvmdk.

I wonder if this is something misconfigured on my machine. Any suggestions on how to debug would be appreciated.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use