VirtualBox

Ticket #9169 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Windows Guest Additions: can't reach last screen pixel with mouse -> duplicate of #7566

Reported by: jmausr Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Windows XP or 7 guest (with additions), Windows 7 host. Apparently this does not happen with a Linux guest (with additions).

The mouse is one pixel off in each axis, except when it's at 0.

For example, mouse coordinates in the host: 0,1,2,3...1279,1280. In the guest: 0,0,1,2...1278,1279. Also, this makes it impossible to reach the last pixel, even if you move the mouse further outside the VM window. A consequence of this is that you can't use Aero Snap on the right side of the screen on W7 guests.

Change History

comment:1 Changed 3 years ago by jmausr

Problem is still present in 4.1.0. Tested on Win7-64 host with WinXP-32 and Win7-32 guests, both with 4.1.0 additions.

comment:2 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Windows Guest Additions: can't reach last screen pixel with mouse to Windows Guest Additions: can't reach last screen pixel with mouse -> duplicate of #7566

This is a duplicate of #7566 and should now be fixed. The following test build for Windows (the usual disclaimers apply) contains the fix.

 http://www.virtualbox.org/download/testcase/VirtualBox-2011-08-05-18-14-54-win-rel-4.1.1-r73349-MultiArch.exe

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use