VirtualBox

Ticket #9161 (closed defect: fixed)

Opened 3 years ago

Last modified 3 months ago

Win7 VM freezes for ~20s while host CPU=100+%

Reported by: dch Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I run VB PUEL 4.0.10 on 64-bit Opensuse 11.4 host.

I installed Windows7 Home Premium 64-bit in a guest.

Everything in the Guest works. Every once in awhile -- not reproducible on demand, but happens frequently -- the VM Guest just pauses. Everything stops. Progress bars stop moving, perf monitors stop scrolling, downloads stop xfer, etc.

Then after ~ 20-30 seconds, everything starts back up again, and continues normally.

There's no errors I've found in any log I've checked, either on host or guest. The one telltale is that, during the period of these pauses, "top" running in shell at the linux host shows VirtualBox's CPU% --> >~ 104%. After those 20-30 secs, when the pause 'releases', CPU utilization goes back down to ~ 10-15%, where it hovers normally.

Here's my VM's config:

vboxmanage showvminfo WIN7 [code] Name: WIN7 Guest OS: Windows 7 (64 bit) UUID: f814907d-07af-f321-7aa8-b492e27a6581 Config file: /home/dchdesk/VBOX/WIN7/WIN7.vbox Snapshot folder: /home/dchdesk/VBOX/WIN7/Snapshots Log folder: /home/dchdesk/VBOX/WIN7/Logs Hardware UUID: f814907d-07af-f321-7aa8-b492e27a6581 Memory size: 2048MB Page Fusion: off VRAM size: 128MB HPET: off Chipset: ich9 Firmware: BIOS Number of CPUs: 1 Synthetic Cpu: off CPUID overrides: None Boot menu mode: message and menu Boot Device (1): Floppy Boot Device (2): DVD Boot Device (3): HardDisk Boot Device (4): Not Assigned ACPI: on IOAPIC: on PAE: on Time offset: 0 ms RTC: local time Hardw. virt.ext: on Hardw. virt.ext exclusive: on Nested Paging: on Large Pages: off VT-x VPID: on State: running (since 2011-07-05T23:22:55.636000000) Monitor count: 1 3D Acceleration: on 2D Video Acceleration: on Teleporter Enabled: off Teleporter Port: 0 Teleporter Address: Teleporter Password: Storage Controller Name (0): IDE Controller Storage Controller Type (0): PIIX4 Storage Controller Instance Number (0): 0 Storage Controller Max Port Count (0): 2 Storage Controller Port Count (0): 2 Storage Controller Bootable (0): on Storage Controller Name (1): SATA Controller Storage Controller Type (1): IntelAhci Storage Controller Instance Number (1): 0 Storage Controller Max Port Count (1): 30 Storage Controller Port Count (1): 2 Storage Controller Bootable (1): on IDE Controller (1, 0): Empty SATA Controller (0, 0): /home/dchdesk/VBOX/WIN7/Win7_C.vmdk (UUID: 5fe6db6b-a274-2c49-c993-f3e90497269c) SATA Controller (1, 0): /home/dchdesk/VBOX/WIN7/Win7_D.vmdk (UUID: 8aac1862-4a83-4fa4-86ac-240859ba404c) NIC 1: disabled NIC 2: MAC: 080027CF49A5, Attachment: Host-only Interface 'vboxnet0', Cable connected: on, Trace: off (file: none), Type: virtio, Reported speed: 0 Mbps, Boot priority: 0 NIC 3: MAC: 080027FD6B9A, Attachment: Bridged Interface 'eth1', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0 NIC 4: disabled NIC 5: disabled NIC 6: disabled NIC 7: disabled NIC 8: disabled Pointing Device: PS/2 Mouse Keyboard Device: PS/2 Keyboard UART 1: disabled UART 2: disabled Audio: enabled (Driver: ALSA, Controller: HDA) Clipboard Mode: Bidirectional Video mode: 1920x924x32 VRDE: disabled USB: enabled

USB Device Filters:

<none>

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>

Shared folders: <none>

VRDE Connection: not active Clients so far: 0

Guest:

OS type: Windows7_64 Additions run level: 2 Configured memory balloon size: 0 MB code

Reading online, I've fiddled with #CPUs, amount of RAM, etc etc -- nothing seems to affect this behavior.

I've added "divider=10" to my grub kernel config. Again, no effect.

Also, setting "kernel.perf_event_paranoid = 2" in sysctl has no effect.

p.s. also see, now, by another user:  http://forums.virtualbox.org/viewtopic.php?f=7&t=42843&p=192572#p192572

Change History

comment:1 Changed 3 years ago by dch

the workaround for this freezing/pausing problem is suggested here:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=42910&p=192897#p192897

namely, to switch from ICH9 -> PIIX3 chipset.

i can confirm that it works here -- no more pauses.

seems like an issue with ICH9 chipset driver.

comment:2 Changed 3 years ago by wacher

comment:3 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use