VirtualBox

Ticket #9127 (closed defect: obsolete)

Opened 3 years ago

Last modified 5 months ago

gluBuild2DMipmaps crash

Reported by: Vino Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by misha) (diff)

My setup information:

Host: Windows 7
Guest: Ubuntu Lucid
Video card: NVidia 8700M GT

Test case:

#include <GL/glew.h>
#include <GL/glu.h>
#include <GL/glfw.h>

int main(int c, char** v)
{   
    glfwInit();

    glfwOpenWindow(100, 100, 0, 0, 0, 0, 16, 0, GLFW_WINDOW);

    GLuint iGLId;
    glGenTextures(1, &iGLId);
    glBindTexture(GL_TEXTURE_2D, iGLId);                                                                                         
    unsigned char iData[256*256*4];
    for (int i = 0; i < 256*256*4; i++)
        iData[i] = 255;

    gluBuild2DMipmaps(GL_TEXTURE_2D,
        4,
        256,
        256,
        GL_RGBA,
        GL_UNSIGNED_BYTE,
        &iData[0]);

    glBindTexture(GL_TEXTURE_2D, 0);
}

(Requires GLFW - "apt-get install libglfw-dev")

Crash stack trace:

0  0x003066e3 in __printf_fp () from /lib/tls/i686/cmov/libc.so.6
#1  0x003012a8 in vfprintf () from /lib/tls/i686/cmov/libc.so.6
#2  0x0032170c in vsprintf () from /lib/tls/i686/cmov/libc.so.6
#3  0x0030a1db in sprintf () from /lib/tls/i686/cmov/libc.so.6
#4  0x008b8d19 in packspu_GetString () from /usr/lib/VBoxOGLpackspu.so
#5  0x007904f3 in cr_glGetString () from /usr/lib/dri/vboxvideo_dri.so
#6  0x0042bb16 in ?? () from /usr/lib/libGLU.so.1
#7  0x00433e38 in gluBuild2DMipmaps () from /usr/lib/libGLU.so.1
#8  0x08048912 in main ()
 

Attachments

VBox.log Download (76.8 KB) - added by Vino 3 years ago.
Log file of a sesson where the crash occurs.

Change History

Changed 3 years ago by Vino

Log file of a sesson where the crash occurs.

comment:1 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions, and if so, attach a fresh VM log here?

comment:2 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use