VirtualBox

Ticket #9125 (closed defect: fixed)

Opened 3 years ago

Last modified 5 months ago

Crash when resuming VM

Reported by: yrro Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Since upgrading to 4.0.10, VirtualBox crashes whenever I resume a saved VM (though I have only tried it twice so far).

Guest is running Linux 2.6.39, host is running Windows Vista.

Attachments

wintermute-2011-06-29-20-34-31.log Download (60.9 KB) - added by yrro 3 years ago.
virtualbox log
Ubuntu-2012-01-05-19-01-14.log Download (62.7 KB) - added by skp 2 years ago.
Debian-SID-2012-04-09-14-57-32-gnome3-abort-from suspend.log Download (64.7 KB) - added by Perryg 2 years ago.

Change History

Changed 3 years ago by yrro

virtualbox log

comment:1 Changed 3 years ago by frank

Does this also happen if you disabled 3D for this VM?

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:3 Changed 2 years ago by yrro

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm still seeing this with 4.1.6. I haven't done an exhaustive test of all options but it usually seems to crash when 3d is enabled and in use (by GNOME Shell).

comment:4 Changed 2 years ago by skp

I'm seeing this issue on two different systems. Both are running Windows 7 x64. Both are using a clean install VirtualBox 4.1.8, followed by a clean install of Ubuntu 11.10. One of them is using 32-bit Ubuntu, the other 64-bit.

apt-get install gnome-shell and select it via login.

Gnome shell requires 3D acceleration for full functionality. With that enabled, Virtualbox crashes 90% of the time loading a saved state. Crashes don't happen without 3D acceleration.

Here's some debug data from visual studio:

...
'VirtualBox.exe': Loaded 'C:\Windows\System32\AudioSes.dll'
'VirtualBox.exe': Loaded 'C:\Windows\System32\wdmaud.drv'
'VirtualBox.exe': Loaded 'C:\Windows\System32\ksuser.dll'
'VirtualBox.exe': Loaded 'C:\Windows\System32\avrt.dll'
'VirtualBox.exe': Loaded 'C:\Windows\System32\msacm32.drv'
'VirtualBox.exe': Loaded 'C:\Windows\System32\msacm32.dll'
'VirtualBox.exe': Loaded 'C:\Windows\System32\midimap.dll'
The thread 'Win64 Thread' (0x1824) has exited with code 0 (0x0).
Unhandled exception at 0x0743cdba in VirtualBox.exe: 0xC0000005: Access violation reading location 0x0000000000000004.
>	VBoxSharedCrOpenGL.dll!000000000743cdba() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for VBoxSharedCrOpenGL.dll]	
 	VBoxSharedCrOpenGL.dll!000000000743cfe6() 	
 	VBoxOGLhostcrutil.dll!00000000025f4519() 	
 	VBoxSharedCrOpenGL.dll!000000000743d06e() 	
 	VBoxSharedCrOpenGL.dll!0000000007454ad7() 	
 	VBoxSharedCrOpenGL.dll!00000000073f92ff() 	
 	VBoxSharedCrOpenGL.dll!00000000073ef0a0() 	
 	VBoxSharedCrOpenGL.dll!00000000073e57a6() 	
 	VBoxSharedCrOpenGL.dll!00000000073e1480() 	
 	VBoxC.dll!000000000377a525() 	
 	VBoxC.dll!000000000377865c() 	
 	VBoxRT.dll!000000000048ab6f() 	
 	VBoxRT.dll!00000000004dd80a() 	
 	msvcr80.dll!0000000073a537d7() 	
 	msvcr80.dll!0000000073a53894() 	
 	kernel32.dll!000000007730652d() 	
 	ntdll.dll!00000000777ec521() 	


000000000743CD5F  mov         esi,edx 
000000000743CD61  mov         edx,dword ptr [rcx] 
000000000743CD63  mov         rbx,r8 
000000000743CD66  test        edx,edx 
000000000743CD68  mov         rdi,rcx 
000000000743CD6B  je          000000000743CF5E 
000000000743CD71  cmp         edx,1702h 
000000000743CD77  je          000000000743CDD8 
000000000743CD79  cmp         edx,8D41h 
000000000743CD7F  je          000000000743CD9F 
000000000743CD81  lea         rcx,[74A04B8h] 
000000000743CD88  mov         r8d,esi 
000000000743CD8B  mov         rbx,qword ptr [rsp+40h] 
000000000743CD90  mov         rsi,qword ptr [rsp+48h] 
000000000743CD95  add         rsp,30h 
000000000743CD99  pop         rdi  
000000000743CD9A  jmp         00000000074921CE 
000000000743CD9F  mov         rcx,qword ptr [r8+98h] 
000000000743CDA6  mov         edx,dword ptr [rdi+4] 
000000000743CDA9  mov         rcx,qword ptr [rcx+20h] 
000000000743CDAD  call        0000000007492246 
000000000743CDB2  mov         r8d,8D41h 
000000000743CDB8  mov         edx,esi 
000000000743CDBA  mov         r9d,dword ptr [rax+4] 

Changed 2 years ago by skp

comment:5 Changed 2 years ago by frank

  • Component changed from other to 3D support
  • Description modified (diff)

comment:6 Changed 2 years ago by Perryg

I have been seeing this for some time but in all of my testing Gnome3 is the one it fails with. Plus I don't think it is Windows specific since I have been seeing this since Gnome3 came out.

comment:7 Changed 17 months ago by guest

I can confirm that this bug still exists in Virtualbox 4.2.4.

Host: Windows (kernel = 6.1.7601, arch = x64)

Guest: Linux (kernel = 3.2.0, arch = x64) running Gnome 3

3D Acceleration: Enabled

comment:8 Changed 6 months ago by misha

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions, and if so, attach a VM log and a  minidump here?

comment:9 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use