VirtualBox

Ticket #9108 (closed defect: fixed)

Opened 3 years ago

Last modified 23 months ago

Machine in sabed state refuses to start with shared drive missing

Reported by: RenHoek Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

I have a Win7 guest running on a Win7 host. The guest is in a saved state. One of the drives on the host system was dropped but it turned out to be exported as a shared folder to the guest.

Problem: I try to start the saved state VM but it breaks off with an error that a shared folder is missing, if I would be so kind to remove it in the settings. However you cannot change the settings on a saved state VM image. (i.e. the 'Settings' option is grayed out)

Expected behaviour: Instead of an error, I expect a popup to either ignore the condition, or remove the shared folder for me and then actually start the saved state VM.

Workaround: Since drive E: was missing, a simple "subst e: c:\" in a dos box solved the problem. I could start the saved state VM and then remove the shared folder.

To recreate the problem: Set up a host and set a drive as a shared folder. Now exit the VM with 'Save state'. Remove the drive from the host and try to start up the VM again. This can be done easiest with 'subst'.

Change History

comment:1 Changed 23 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

This was fixed long time ago (I think in VBox 4.1).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use