VirtualBox

Ticket #9068 (reopened defect)

Opened 3 years ago

Last modified 2 months ago

Guest Memory leak when using "guestcontrol execute" => Fixed in SVN

Reported by: goesen Owned by:
Priority: major Component: guest control
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

64 bit linux host 32 bit linux guest Virtualbox 4.08

on host running: while [ true ]; do VBoxManage --nologo guestcontrol execute $MACHINE --username $USER /bin/ls; done

in guest system memory allocation of VboxService is skyrocketing!

Attachments

ps_and_times.log Download (133.9 KB) - added by YoannR 2 months ago.
Output of "ps aux" for each invocation of "guestcontrol execute"
VBox.log Download (60.0 KB) - added by YoannR 2 months ago.

Change History

comment:1 Changed 3 years ago by frank

  • Summary changed from Guest Memory leak when using "guestcontrol execute" to Guest Memory leak when using "guestcontrol execute" => Fixed in SVN

Thanks for the report, will be fixed in the next maintenance release.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 4.0.10, please update your Guest Additions.

comment:3 Changed 3 years ago by goesen

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sry, but nothing has changed at all.

I updated my Guest Additions and my Host service. Checked VBoxManage,VBoxServive and kernel modules

Everything is on 4.0.10 r72479. And still rapid execution of commands like posted above will make VBoxService allocate memory until it gives up. Message on host:

VBoxManage: error: Process could not be started: VERR_NO_MEMORY.

and after a few dozens of that comes the final deadblow VBoxManage: error: Invalid user/password credentials.

comment:4 follow-up: ↓ 5 Changed 3 years ago by frank

Well, there was definitely a bug which was fixed. The command line you posted would not work because it does not contain a password. In that case, some memory was leaked. But there might be other code pathes leaking memory as well.

comment:5 in reply to: ↑ 4 Changed 3 years ago by goesen

Replying to frank:

Well, there was definitely a bug which was fixed. The command line you posted would not work because it does not contain a password. In that case, some memory was leaked. But there might be other code pathes leaking memory as well.

Well in Version 4.0.10 both the command

while [ true ]; do VBoxManage --nologo guestcontrol execute $MACHINE --username $USER --password $PASSWORD /bin/ls; done 

as well as the command

while [ true ]; do VBoxManage --nologo guestcontrol execute $MACHINE --username $USER /bin/ls; done 

is leaking memory. So i don't think this bug should be considered fixed

comment:6 Changed 3 years ago by goesen

Seems like that memory leak is caused by the guestadditions reading stdout, and not deallocating memory after doing so. Just execute /usr/bin/yes-> memory get's exhausted in a few seconds

comment:7 Changed 3 years ago by pentagonik

@goesen: Thanks for the report. For 4.1.2 we've implemented a guest process policy by serving up to 5 processes at once. This limit can be increased/decreased or even deactivated if needed then.

comment:8 Changed 3 years ago by frank

  • Component changed from other to guest control

Changed 2 months ago by YoannR

Output of "ps aux" for each invocation of "guestcontrol execute"

Changed 2 months ago by YoannR

comment:9 Changed 2 months ago by YoannR

I still have this kind of problem with 4.3.6, host: Debian Wheezy 64 bits, guest: Windows Server 2008 64 bits.

When executing the following script on host:

while [ 1 ]; do
    vboxmanage guestcontrol win2k8-newvbox execute "C:\Windows\System32\ping.exe" --username Administrator --password "some_password" --verbose --wait-stdout --wait-stderr --wait-exit -- "-n" "20" "1.1.1.1" >>vbox_exec.log
    ps aux >>vbox_exec.log
done

I can see the virtualbox process memory consumption rise to several GB.

Please find attached a VBox.log file, and a regular output of 'ps aux' (once between each invocation of 'guestcontrol execute').

If you need any further information, I will do my best to provide you with it. If you prefer me to open a new ticket for this problem, please let me know and I will do so.

Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use