VirtualBox

Ticket #8977 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VRDE server drawing problems with windows guests.

Reported by: mduft Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: other
Host type: other

Description

I recently switched from the SDL GUI to running all VMs headless, and accessing the console through the VRDE servers. For some reason there are very strange drawing problems in conjunction with the windows console (used for interix in my case, but that should not make a difference).

you can find a screen capture of the problem at [1]. it happens with windows server 2003R2 and windows 7. Strange enough, the windows XP guest seems unaffected (VRDE settings are the same for all). If i rdesktop to the guest instead of the VRDE server, things work perfectly.

i'm on linux, of course, and i tried the rdesktop-vrdp client bundled with vbox and gentoo's rdesktop 1.7.0, both with the same results.

rdesktop sometimes moans something like this:

ERROR: order parsing failed
ERROR: order parsing failed
NOT IMPLEMENTED: secondary order 108
ERROR: order parsing failed
ERROR: order parsing failed
ERROR: order parsing failed
ERROR: order parsing failed
NOT IMPLEMENTED: order 249
NOT IMPLEMENTED: order 249

if it helps: the log for the session in the screen recording is attached.

[1]  http://dev.gentoo.org/~mduft/vbox-vrde.mp4

Attachments

VBox.log Download (48.4 KB) - added by mduft 3 years ago.

Change History

Changed 3 years ago by mduft

comment:1 Changed 3 years ago by mduft

also, sometimes, the rdesktop window just disappears. i didn't manage to get a return code or output from rdesktop in this case (as i start it through a script). however, the virtualbox log shows these:

 994 03:05:19.070 VRDP: Connection closed:
 995 03:05:19.070 VRDP: Logoff: s01en01 (172.28.8.14) build 2600. User: [mduft] Domain: [] Reason 0xFFFFFFFF.
 996 03:05:19.070 VBVA: VRDP acceleration has been disabled.

reason 0xFFFFFFFF looks strange, right?

comment:2 Changed 3 years ago by sunlover

Can't reproduce the problem here. Could you please compile rdesktop with WITH_DEBUG and WITH_DEBUG_RDP5 defines, then reproduce the problem and send me the log to Vitali dot Pelenjow at oracle dot com?

PS: 0xFFFFFFFF is ok. Most likely connection is dropped because the client can't parse some data.

comment:3 Changed 3 years ago by mduft

the problem seems to appear only after some while of scrolling output on the terminal. how about running dir in a loop? that should repro it too. i'll have another look at it.

comment:4 Changed 3 years ago by mduft

i ran a simple batch script in a vm:

:TOP
dir
goto :TOP

it didn't reproduce the exact same problem, but the console window contents gets messed up after a few seconds to minutes of running the script, and stays garbled when scrolling up/down. only after moving the window or minimizing and restoring, the contents is ok again.

i sent you log files for my actual issue i reported (rd.log.bz2), and the batch file run (rd2.log.bz2)

comment:5 Changed 3 years ago by mduft

the pre-release 4.10 extpack seems to resolve the problems i have been seeing. at least for some hours now, nothing bad happened at all. it is a little bit slower than before i think, but thats better than a fast-not-working solution IMHO :)

thanks

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix in VBox 4.0.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use