VirtualBox

Ticket #8948 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VBox unable to start virtual machine due to strange character in .vbox file => Fixed in SVN

Reported by: carvalhais1981 Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords: invalid char, unaccessible
Cc: Guest type: Windows
Host type: Linux

Description

Hi,

After launching Virtual Box, on my Linux Host (Debian Squeeze 64 bit, VBox binaries from the official virtualbox.org repositories) one of my VM's (Windows 7 Guest 64 bit) is listed as not being accessible according to the following error message:

PCDATA invalid Char value 3.
Location: '/home/carvalhais/Máquinas Virtuais/Win 7 - Trabalho/Win 7 - Trabalho.vbox', line 618 (3), column 36.
/home/vbox/vbox-4.0.8/src/VBox/Main/src-server/MachineImpl.cpp[679] (nsresult Machine::registeredInit()).
Código de Resultado: 
NS_ERROR_FAILURE (0x80004005)
Componente: 
VirtualBox
Interface: 
IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff

Googling around, I came across some other users having the same issue (see topic  http://forums.virtualbox.org/viewtopic.php?f=7&p=187762 in user forums), and as one of them suggested, editing the .vbox file revealed a strange character that was preventing the machine from start (in my case I just removed it, and the VM started working again).

Apparently in none of the cases anything was done to introduce the error. I also noticed we were all running 64 bit Debian based hosts and 64 bit Windows 7 guests, so this may be a particularized error.

I cannot confirm this error was introduced after upgrading VBox itself or the Guest Additions (as it is suggested in the user forums topic), since I was able to run the VM after the upgrade without any problems for a couple of times. However, the problem appeared after Windows did an automatic update (I do not know if this can interfere with VBox engine). Attached is my original .vbox files (with the strange char still in it).

Thanks in advance, wishing to hear from you soon,

André.

Attachments

Win 7 - Trabalho.vbox.201105222327 Download (42.2 KB) - added by carvalhais1981 3 years ago.
Defective .vbox file
Win 7 Again.vbox Download (11.2 KB) - added by kjbucknum 3 years ago.
VBox.log.1 Download (65.7 KB) - added by kjbucknum 3 years ago.
linms2008.jpg Download (103.8 KB) - added by oreomatic 3 years ago.
LinMSS2008.vbox.txt Download (11.6 KB) - added by oreomatic 3 years ago.
oreomatic's vbox file with error still in it
VBox.log.3.txt Download (76.6 KB) - added by oreomatic 3 years ago.
oreomatic's most recent log file
VBox.log.2.txt Download (37.5 KB) - added by oreomatic 3 years ago.
oreomatic's second most recent log file
Win7.vbox Download (12.7 KB) - added by darrenjrobinson 3 years ago.
Win7 VM on Ubuntu 11.04 AMD64 PCDATA invalid Char value 3.
Windows Vista.xml Download (9.0 KB) - added by harphauler 3 years ago.
VBox.log Download (82.2 KB) - added by harphauler 3 years ago.
Window7x64.vbox Download (22.7 KB) - added by draptik 3 years ago.
vbox file for Win7 (64bit) guest on Ubuntu 11.04 (64bit)
VBox.2.log Download (72.8 KB) - added by draptik 3 years ago.

Change History

Changed 3 years ago by carvalhais1981

Defective .vbox file

comment:1 in reply to: ↑ description Changed 3 years ago by kjbucknum

Adding myself to this ticket per PerryG's request here.  http://forums.virtualbox.org/viewtopic.php?f=7&t=41725&start=15

Changed 3 years ago by kjbucknum

Changed 3 years ago by kjbucknum

comment:2 Changed 3 years ago by kjbucknum

If that is not the log file he wanted, let me know.

Changed 3 years ago by oreomatic

Changed 3 years ago by oreomatic

oreomatic's vbox file with error still in it

Changed 3 years ago by oreomatic

oreomatic's most recent log file

Changed 3 years ago by oreomatic

oreomatic's second most recent log file

Changed 3 years ago by darrenjrobinson

Win7 VM on Ubuntu 11.04 AMD64 PCDATA invalid Char value 3.

comment:4 Changed 3 years ago by darrenjrobinson

Same error as everyone else. Been working great, but bam no joy this morning. Attached my .vbox file. Running Ubuntu 11.04 AMD64. VBox 4.0.8 r71778 VM is Windows 7 64-bit.

comment:5 Changed 3 years ago by frank

Confirmed. There are two problems:

  1. The invalid value of the VersionEx guest property is written into the XML file, this should not happen.
  2. The value of the VersionEx guest property is invalid at all. This is a 4.0.8 regression where one variable was not properly initialized. This should only affect Windows guests. If the guest cannot boot, just edit the XML file manually (make sure that no other VM is running and that VBoxSVC isn't running) and fix the file by replacing the invalid string with "4.0.8".

comment:6 Changed 3 years ago by AoS

Same issue. Virtualbox 4.0.8 with host running Ubuntu 11.04 (64 bit) and guest running Windows 7 (64 bit).

comment:7 follow-up: ↓ 8 Changed 3 years ago by harphauler

Same issue. Virtualbox 4.0.8 with host running Ubuntu 10.10 (64 bit) and guest running Windows Vista (64 bit) My workaround is to open Windows Vista.xml file and delete the character referenced, save, start vbox & the Vista machine. Thanks.

Error Msg - PCDATA invalid Char value 3. Location: '/home/lou/.VirtualBox/Machines/Windows Vista/Windows Vista.xml', line 83 (3), column 36. /home/vbox/vbox-4.0.8/src/VBox/Main/src-server/MachineImpl.cpp[679] (nsresult Machine::registeredInit()). Result Code: NS_ERROR_FAILURE (0x80004005) Component: VirtualBox Interface: IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}

attached files, ../.VirtualBox/Machines/Windows Vista.xml; ../.VirtualBox/Machines/Windows Vista/Logs/VBox.log

Changed 3 years ago by harphauler

Changed 3 years ago by harphauler

comment:8 in reply to: ↑ 7 Changed 3 years ago by harphauler

Replying to harphauler: Don't know if this is a help or not but have tried replacing the strange character in line 83 with "4.0.8", "4.0.8r71778", and "71778" all with no joy - on shut down the value is replaced with a strange character.

comment:9 follow-ups: ↓ 10 ↓ 12 Changed 3 years ago by frank

In that case please do the following:

  1. Edit the settings file to allow the VM to start again.
  2. Start the Windows guest
  3. Run regedit
  4. Go to HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions
  5. Create a string key VersionEx (use exactly this spelling)
  6. Give it a reasonable value
  7. Shut down the VM.

comment:10 in reply to: ↑ 9 ; follow-ups: ↓ 11 ↓ 13 Changed 3 years ago by harphauler

Replying to frank: Interesting. This may have fixed my problem. On the first Windows and Vbox shut down after performing your instructions, using "4.0.8" as the registry value for the newly created string, my line 83 was: <GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value="L" timestamp="1306339257786578000" flags=""/> After manually editing the value= to "4.0.8" I have now successfully started and shut down three times without incident. Will try a few more repetitions. Thank you.

In that case please do the following:

  1. Edit the settings file to allow the VM to start again.
  2. Start the Windows guest
  3. Run regedit
  4. Go to HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions
  5. Create a string key VersionEx (use exactly this spelling)
  6. Give it a reasonable value
  7. Shut down the VM.

comment:11 in reply to: ↑ 10 Changed 3 years ago by harphauler

Replying to harphauler: VBox still working just fine after a few more start/shut downs. Don't know if this will help but following is my complete Windows Registry entry after modification. The only change is/was addition of your string key:

(Default) REG_SZ (value not set) InstallDir REG_SZ C:\Program Files\Oracle\VirtualBox Guest Additions Revision REG_SZ 71778 Version REG_SZ 4.0.8 VersionEX REG_SZ 4.0.8 VersionExt REG_SZ 4.0.8

Replying to frank: Interesting. This may have fixed my problem. On the first Windows and Vbox shut down after performing your instructions, using "4.0.8" as the registry value for the newly created string, my line 83 was: <GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value="L" timestamp="1306339257786578000" flags=""/> After manually editing the value= to "4.0.8" I have now successfully started and shut down three times without incident. Will try a few more repetitions. Thank you.

In that case please do the following:

  1. Edit the settings file to allow the VM to start again.
  2. Start the Windows guest
  3. Run regedit
  4. Go to HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions
  5. Create a string key VersionEx (use exactly this spelling)
  6. Give it a reasonable value
  7. Shut down the VM.

Changed 3 years ago by draptik

vbox file for Win7 (64bit) guest on Ubuntu 11.04 (64bit)

Changed 3 years ago by draptik

comment:12 in reply to: ↑ 9 Changed 3 years ago by draptik

Replying to frank:

In that case please do the following:

  1. Edit the settings file to allow the VM to start again.
  2. Start the Windows guest
  3. Run regedit
  4. Go to HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions
  5. Create a string key VersionEx (use exactly this spelling)
  6. Give it a reasonable value
  7. Shut down the VM.

I can also confirm that this workaround works (although I needed another restart/shutdown cycle of the guest system, just like harphauler).

Thanks for your help Frank!

comment:13 in reply to: ↑ 10 Changed 3 years ago by harphauler

Replying to harphauler: After several start, shut down cycles I feel it safe to confirm that this has fixed my problem. Thank you Frank!

In that case please do the following:

  1. Edit the settings file to allow the VM to start again.
  2. Start the Windows guest
  3. Run regedit
  4. Go to HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions
  5. Create a string key VersionEx (use exactly this spelling)
  6. Give it a reasonable value
  7. Shut down the VM.

comment:14 Changed 3 years ago by frank

  • Summary changed from VBox unable to start virtual machine due to strange character in .vbox file to VBox unable to start virtual machine due to strange character in .vbox file => Fixed in SVN

Thanks for the report. This bug will be fixed with the next maintenance release.

comment:15 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix in VBox 4.0.10, make sure to update the Guest Additions!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use