VirtualBox

Ticket #8929 (reopened defect)

Opened 3 years ago

Last modified 3 years ago

undoc'd Windows XP trick does not work in virtualbox (active partitons)

Reported by: Charlieb000 Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.1.2 Keywords: Active partition
Cc: Guest type: Windows
Host type: other

Description

do this on a real computer: run UBCD and mark the sole partition of your computer active using MMC. reboot without disk, and you should receive error: NTLDR missing. Press Ctrl+Alt+Del to reboot.

then i copy contents of windows drive to the disk and it runs because NTLDR is copied.

do the same in virtualbox and i get FATAL: No bootable medium found! system halted. obviously a virtualbox error, not seeing the active partition on the virtual drive.

This virtual drive was created using version 1.62 as i was using a win2k host at the time, but the copying was done using the 3.1.2 (and failed to boot), and tried running it on 4.0.8 and not going.

UBCD mmc still reports there is a single partition on the drive, and is active. 160GB drive, 48GB partition.

currently vista host 4.0.8 and not yet a XP sp1 guest.

cb.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

AFAIK the error message NTLDR missing. Press Ctrl+Alt+Del to reboot comes from the boot sector of the partition which you marked as bootable. If there was nothing installed on this partition before then you will not get anything. So it's not a VirtualBox bug.

comment:2 Changed 3 years ago by Charlieb000

  • Status changed from closed to reopened
  • Resolution invalid deleted

you did not read entire message. i wish you had more time.

yes NTLDR error comes from boot sector, but i cannot reproduce this error on the virtualbox. what i do then to fix the error is to copy the OS on and it works.

i started to install another MS OS which "fixed" it as it saw it in the other partition. CB.

comment:3 Changed 3 years ago by Charlieb000

what i do then to fix the error (on a normal PC) is to copy the OS on and it works.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use