VirtualBox

Ticket #8906 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

Virtual Machine inaccessible after upgrading to latest VBox and guest additions

Reported by: dhdurgee Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Windows
Host type: other

Description

I run several versions of Windows in Virtual Box here. After the new release installed I first booted W7 and updated the guest additions. I next booted XP and updated the guest additions. After shutting XP down that VM now shows as "Inaccessible", but I can read the machine profile fine using MC.

Attachments

VBox.log Download (76.4 KB) - added by dhdurgee 3 years ago.
log from last boot of XP machine
Window_XP_Test.xml Download (9.6 KB) - added by dhdurgee 3 years ago.
virtual machine profile
VirtualBox.xml Download (4.1 KB) - added by dhdurgee 3 years ago.
virtual box profile

Change History

Changed 3 years ago by dhdurgee

log from last boot of XP machine

Changed 3 years ago by dhdurgee

virtual machine profile

Changed 3 years ago by dhdurgee

virtual box profile

comment:1 in reply to: ↑ description Changed 3 years ago by dhdurgee

Replying to dhdurgee:

I run several versions of Windows in Virtual Box here. After the new release installed I first booted W7 and updated the guest additions. I next booted XP and updated the guest additions. After shutting XP down that VM now shows as "Inaccessible", but I can read the machine profile fine using MC.

Forgot to note, host is Linux Mint 8 Helena - x64 Edition

comment:2 Changed 3 years ago by dhdurgee

Per a suggestion I saw I ran VBoxManage list vms --long and got the following for the machine in question:

dhdurgee@DG41TY ~/Downloads $ VBoxManage list vms --long Name: <inaccessible!> UUID: 7e38f6c7-22a2-41f8-a737-f53574913132 Config file: /home/dhdurgee/.VirtualBox/Machines/Window_XP_Test/Window_XP_Test.xml Access error details:

VBoxManage: error: Details: code NS_OK (0x0), component , interface , callee

I can cat the config file noted above, which of course is the one I attached earlier. What does the error above imply needs to be done to correct this?

comment:3 Changed 3 years ago by dhdurgee

I also just thought to run a validation of the xml files and they come back clean.

comment:4 Changed 3 years ago by dhdurgee

I tried getting details via UUID and got the following:

dhdurgee@DG41TY ~/Downloads $ VBoxManage showvminfo "7e38f6c7-22a2-41f8-a737-f53574913132" Name: <inaccessible!> UUID: 7e38f6c7-22a2-41f8-a737-f53574913132 Config file: /home/dhdurgee/.VirtualBox/Machines/Window_XP_Test/Window_XP_Test.xml Access error details: VBoxManage: error: The object functionality is limited VBoxManage: error: Details: code E_ACCESSDENIED (0x80070005), component Machine, interface IMachine, callee

Does this help?

comment:5 Changed 3 years ago by klaus

If you tell me how you can produce this VM config file without manually editing it I might be able to find the root cause.

The cause why the config file is rejected is that there are two DVD drives in the config, both pointing to the same DVD image. VirtualBox cannot handle this.

Already found the place which didn't produce an error message...

Repairing the Window_XP_Test.xml file is relatively easy: delete one of the two occurrences of '<Image uuid="{128c07dc-7635-47bf-b542-a7129de5aa0a}"/>'.

comment:6 Changed 3 years ago by dhdurgee

That did repair the virtual machine. Thanks for the pointer.

As to how the condition obtained, my recollection is that some time ago I had mounted the guest additions CD image as the IDE controller 1 slave unit while I had one of the system DVD drives as the IDE controller 1 master unit. I had booted the XP image shortly after the update was installed and selected "install additions" from the Device menu. Is it possible that this replaced my 1,0 unit with the guest additions image despite it already being attached as the 1,1 unit? This would match conditions, as after I shutdown the VM I started seeing the problems. Is it possible to confirm this from the log file?

Dave

comment:7 Changed 3 years ago by klaus

  • Status changed from new to closed
  • Resolution set to worksforme

At least with the current version I couldn't reproduce problems with such "double mounting" of the guest additions iso - any attempt to save such a config is rejected and results in a rollback to the previous configuration. It's of course possible that there were earlier VirtualBox versions which didn't contain this consistency check.

The log files probably won't help - the problem might have been long dormant, and only the logs for the last 4 runs are kept.

comment:8 Changed 3 years ago by dhdurgee

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I just encountered the same problem again today! Now that I know how to deal with it I simply edited the XML for the virtual machines and that was that.

The circumstances were the same as last time. In the two machines I had problems with the IDE-secondary-slave was the windows extensions and the IDE-secondary-master was a host DVD drive. After I booted my machines with new release clicked "Device-Install Guest Additions" to install the updated additions. This did the install and I shutdown normally. But as I encountered the problem again this morning when I prepared to boot the VM it appears that this process does not check to see if the guest additions is already mounted, in this case as the IDE-secondary-slave, and UNCONDITIONALLY mounts it in place of the CD device first in the list before starting it.

Hopefully I will remember this next time an update arrives and will run it manually from the currently mounted drive as opposed to using the "Device-Install Guest Additions" menu entry. Hopefully this is enough information for you to recreate and fix the problem.

comment:9 Changed 3 years ago by dhdurgee

I ran the update from the mounted ISO image this month and things went fine. I will leave it to someone else to test this by mounting this ISO image as a secondary DVD/CD drive and then using the "Device-Install Guest Additions" menu entry to see if the problem manifests itself for them, as I don't have the time to waste manually editing a mangled configuration file.

comment:10 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use