VirtualBox

Ticket #8806 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Too many files Open

Reported by: Ladislav Owned by:
Priority: major Component: host support
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi, I have a Linux amd64 host. After running a Windows guest for about two weeks the machine lost its network connection (port forwarding didn't work). I tried to save the state of the machine and I got too many open files error and the machine got stuck.

I had to kill the machine and start it again. Log is attached.

I have noticed that the VirtualBox process opens /dev/zero many many times, which might be the cause since the number of open instances slowly increases over time.

# lsof | grep "VirtualBo" |grep "/dev/zero" | wc -l
3913

I believe this might be related to ticket #6464, however in this case the error appeared over time by itself.

Attachments

VBox.log Download (132.1 KB) - added by Ladislav 3 years ago.

Change History

Changed 3 years ago by Ladislav

comment:1 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use