VirtualBox

Ticket #8749 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Can not enable some desktop effects of KWin

Reported by: RussianNeuroMancer Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I try enable desktop effects in fresh Kubuntu 11.04 Beta 2 guest installation (VirtualBox 4.0.5 Guest Additions pre-release is installed) and find the follow effect can not be enabled: Cover Switch Desktop Cube Magic Lamp Startup Feedback

Host is also Kubuntu 11.04 Beta with Catalyst 11.4 pre-release, but it's doesn't matter because bug is reproduced on any host OS with any GPU and any GPU driver, then problem probably in VirtualBox guest GPU driver.

Change History

comment:1 Changed 3 years ago by RussianNeuroMancer

Also when I try to restart KWin (kwin --replace &) it's says "KWin::Workspace::setupCompositing: KWin has detected that your OpenGL library is unsafe to use, falling back to XRender." and "Failed to initialize compositing, compositing disabled".

comment:2 Changed 3 years ago by RussianNeuroMancer

Also now is absolutely clear why KWin can not enable Cover Switch, Desktop Cube, Magic Lamp and Startup Feedback - it's not available in XRender mode. But why KWin uses XRender instead of OpenGL? KWin developer says "texture from pixmap is clearly failing" (  http://bugs.kde.org/show_bug.cgi?id=269594 ) than "in Virtualbox KWin automatically falls back to XRender and given that this has to be fixed by Oracle".

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4582.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use