Opened 17 years ago

Closed 16 years ago

#87 closed defect (duplicate)

USB Webcam not working

Reported by: mflash Owned by:
Component: USB Version: VirtualBox 1.3.4
Keywords: usb webcam Cc:
Guest type: other Host type: other


Running VirtualBox 1.3.4 on an ASUS W7J laptop, kernel 2.6.19 (Arch Linux).

This machine has an internal SONIX webcam (0c45:624f) which has no native Linux drivers.

I've managed to sucessfully install the webcam drivers on guest Windows XP with SP2 but when it is activated, I get only a black screen. Then I've tested a Logitech QuickCam 3000, and it worked fine, albeit the frame rate was quite lower than I remembered.

Interestingly, the black screen effect also happened when I tried to install the webcam drivers on a native Windows XP partition without first installing USB 2.0 support (i.e. SP2): Windows warned that "a high-bandwidth peripheral was connected to a low-bandwidth bus".

May this indicate a bug in the VirtualBox USB code ? Please let me know if I can provide you with further info.

Change History (5)

comment:1 by mflash, 17 years ago

FIY, tried the same with VMware Beta 6.0 (which has included support for USB 2.0) and it works fine, so it's not a driver problem.

comment:2 by jiff, 17 years ago

I also have a PB with a Philips PCVC740K (toUcam pro):

I can boot XP with the cam plugged-in, but if I try to open the "my computer > Philips Webcam" icon, I'm savagely disconnected (same if I plug-in webcam after boot is completed).


comment:3 by asterix86, 17 years ago

I have a problem too with logitech pro 5000 webcam. I install the driver, but when I run logitech program, it doesn't detect the webcam. Each time I disconnect / reconnect the webcam windows asks me to install it.

comment:4 by Frank Mehnert, 16 years ago

Component: otherUSB

comment:5 by Sander van Leeuwen, 16 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #242.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use