VirtualBox

Ticket #8638 (closed defect: fixed)

Opened 3 years ago

Last modified 13 months ago

Guest Additions: Shared Folders Auto-Mount fails on RHEL4 => Fixed in SVN

Reported by: Technologov Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: other

Description (last modified by frank) (diff)

Host: Windows 7, x64, VBox 4.0.4 (and 4.0.0)

Guest: Linux - RHEL 4 (32+64bit)

When using new VBox 4.0 feature, called "Shared Folders Auto-Mount", it fails to Auto-mount on RHEL 4 guests, probably due to old kernel.

dmesg output:

vboxsf: no version for "RTSemFastMutexCreate" found: kernel tainted.

Manual mounting works fine. Auto-Mount works on other Linux guests.

-Technologov, 27.3.2011.

Attachments

RHEL 4 32-bit-2011-03-27-22-16-44.log Download (52.7 KB) - added by Technologov 3 years ago.
VBox Log

Change History

Changed 3 years ago by Technologov

VBox Log

comment:1 Changed 3 years ago by michael

Do you still get that message if you disable auto-mount? And in this case does manual mounting still work first time?

comment:2 Changed 3 years ago by Technologov

Do you still get that message if you disable auto-mount?

Yes.

And in this case does manual mounting still work first time?

Yes.

-Technologov

comment:3 Changed 3 years ago by Technologov

Any idea on this one?

comment:4 Changed 3 years ago by frank

No idea. This works fine here with my CentOS 4 guest.

comment:5 Changed 3 years ago by Technologov

Update: this only happens if I create non-permanent (transient) shared folders.

Steps to reproduce:

  1. Start RHEL 4 VM (and pause it)
  1. Configure transient shared folders with auto mount.
  1. resume booting VM

Actual Result: VM will boot, but shared folder will not be auto-mounted.

-Technologov

comment:6 Changed 3 years ago by Technologov

Does it help ?

comment:7 Changed 3 years ago by michael

If I understand comment 5 correctly, you are creating the folders to be mounted during the VMs boot. As far as I know the mounting is done at boot time - are you sure you aren't just adding them after the auto-mounting has already taken place?

comment:8 Changed 3 years ago by Technologov

I start VM and pause it at bootloader stage. This happens before GuestOS loads.

I am sure, because the same works with other Linuxes. Only RHEL4 fails.

comment:9 Changed 3 years ago by michael

And do the folders auto-mount if you add them before starting the VM? For that matter, do they auto-mount on the next boot if you add them while the machine is paused like you described?

comment:10 Changed 3 years ago by Technologov

And do the folders auto-mount if you add them before starting the VM?

Before you start VM you cannot add transient shared folders. Only permanent. Those work.

For that matter, do they auto-mount on the next boot if you add them while the machine is paused like you described?

No.

comment:11 Changed 3 years ago by michael

I don't think that auto-mounting of transient folders is supposed to work, although it seems that it does by chance in some guests. You say though that auto-mounting permanent folders does work, which is what is supposed to happen.

comment:12 Changed 3 years ago by Technologov

Auto-mount of transient folders works on *all* guests, except RHEL 4.

comment:13 Changed 3 years ago by michael

Nonetheless it is not a supported feature. I will take a look at it if I have to set up a RHEL/CentOS 4 guest for something else, but I'm afraid it isn't really the highest priority just now.

comment:14 Changed 14 months ago by frank

  • Description modified (diff)
  • Summary changed from Guest Additions: Shared Folders Auto-Mount fails on RHEL4 to Guest Additions: Shared Folders Auto-Mount fails on RHEL4 => Fixed in SVN

Actually the reason was a crash in VBoxService on old systems where libdbus is not installed. This will be fixed in the next maintenance release.

comment:15 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.2.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use