VirtualBox

Ticket #8630 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

the VM just crashed

Reported by: wacher Owned by:
Priority: critical Component: VMM
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I don't know what happend, the VM just crashed. This isn't the first time, but now the VM wrote log. The guest system did nothing heavy, it was just idle.

VBox process stopped, VM state is aborted that is all what i know.

Attachments

VBox.log Download (109.3 KB) - added by wacher 3 years ago.
Log after a crash
VBox.log.1 Download (52.2 KB) - added by wacher 3 years ago.
I just started again…
4.1.4r74291_VBox_1280MB_ok.log Download (75.0 KB) - added by wacher 3 years ago.
1280 MB RAM dedicated to guest
4.1.4r74291_VBox_1408MB_failed.log Download (50.3 KB) - added by wacher 3 years ago.
1408 MB RAM dedicated to guest
4.1.4r74291_VBox_1536MB_failed.log Download (53.3 KB) - added by wacher 3 years ago.
1536 MB RAM dedicated to guest

Change History

Changed 3 years ago by wacher

Log after a crash

Changed 3 years ago by wacher

I just started again...

comment:1 Changed 3 years ago by wacher

For second log:

I started the VM again, but i could not "save state" because VERR_MAP_FAILED. I clicked 'OK' on the message box, but thereafter VBOX_E_INVALID_VM_STATE happend. See attached logfile.

comment:2 Changed 3 years ago by frank

Of course this is a bug but I assume the VM will not crash if you decrease the amount of guest RAM.

comment:3 Changed 3 years ago by wacher

How much RAM is recommended? Do you think that 1,5 GB is too high? (total is 3GB)

comment:4 Changed 3 years ago by frank

1.5GB is supposed to work but I guess your guest will run much better with 1GB and often this is sufficient anyways.

comment:5 Changed 3 years ago by wacher

In this laptop was 2GB RAM. (1G host + 1G guest). I bought an extra 1GB RAM yesterday, W7 with 1GB is OK and usable but not smooth. But this crash occured several times with 2GB RAM too.

1 crash per 1-3 day is very annoying, I will try 1GB guest RAM for a week or until next vbox release.

Thank you for your advice.

comment:6 Changed 3 years ago by wacher

comment:7 Changed 3 years ago by wacher

Don't really matters how much memory I use for VM. Very annoying and I had the first dataloss as well. So not only annoying, but definitely dangerous.

comment:8 Changed 3 years ago by wacher

I use now 4.0.6, the problem still exists, but something is better.

I use now 1280MB RAM (in accordance of frank's advice), Vbox runs smoothly. I can take a snapshot, and there is no random crash. If I increase the amount of RAM to 1536MB, everything changes :( If I decrease to 1280 MB, that's OK.

comment:9 Changed 3 years ago by wacher

I tested this problem some days ago (4.0.8) . Nothing has changed for the better. I'm very sad, I have a lot of free RAM which I can't utilize :(

comment:10 Changed 3 years ago by frank

Yes, there must be still a bug in VBox but by installing a 64-bit host operating system you could solve that issue properly. On 32-bit hosts VirtualBox, unmaps parts of the guest memory if the guest touched more than 1GB RAM as the maximum usable address space on 32-bit host is less than 2GB. All this is not necessary with a 64-bit address space.

comment:11 Changed 3 years ago by frank

Could be fixed with VBox 4.1.4, could you test again?

comment:12 Changed 3 years ago by wacher

Hello frank,

I'm sorry to tell, but I found nothing changed. I could repeat what I wrote above. Till 1280 MB is OK. I attach some logs.

Changed 3 years ago by wacher

1280 MB RAM dedicated to guest

Changed 3 years ago by wacher

1408 MB RAM dedicated to guest

Changed 3 years ago by wacher

1536 MB RAM dedicated to guest

comment:13 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7929.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use