VirtualBox

Ticket #8614 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Damage to .vbox file for first VM renders all VMs inacessible and VM Manager empty

Reported by: ChrisJenkins Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I have 4 VMs con figured. They are all configured similarly to the attached .vbox file.

I had a situation where for unexplained reasons (subject of much discussion but no conclusion as yet) the .vbox file for the first VM that I had defined becamed 'damaged'. By this I mean that three of the 'HardDisk' entries in the 'MediaRegistry' section were removed. The relevant entries for these disks were still present in the 'AttachedDevice' section at the end of the file.

When I opened the VBox GUI, all 4 VMs were shown as 'inacessible', even though there was no problem with the .vbox files for the other three VMs, and when I opened the Virtual Media Manager that also showed as 'empty' (i.e. no media was listed).

I have performed some experiments and have confirmed the following:

  1. This behaviour only happens when the .vbox file for the first defined VM

is 'damaged'. It seems this VM is somehow 'special' from the perspective of its Media Registry?

  1. This behaviour happens consistently when I deliberately 'damage' the .vbox file

for the first VM. Removing just one 'HardDisk' entry that is specific to that VM renders all VMs inaccessible and the VMM 'empty'.

This behaviour isn't very nice. A problem with the .vbox file for the first defined VM should not have any impact on other VMs nor on the Virtual Media Manager.

Change History

comment:1 Changed 3 years ago by ChrisJenkins

Duplicate of ticket #8615 (browser problem). Please close.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use