VirtualBox

Ticket #8594 (closed defect: worksforme)

Opened 3 years ago

Last modified 22 months ago

Memory corruption on reboots

Reported by: taisph Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

If I boot my Ubuntu guest and choose to restart at login prompt and then boot the memtest image, the test randomly fails claiming bad memory at random locations and shortly after always crashes virtualbox completely.

Booting the memtest image from cold start allows me to complete the memtest without any problems or crashes.

I've tried changing chipset, IO APIC, number of CPUs, PAE/NX, VT-x, Nested paging flags without any luck.

Host: Windows 7 Ultimate 64-bit SP1 Guest: Ubuntu 10.10

Attachments

memtest.PNG Download (83.9 KB) - added by taisph 3 years ago.
memtest snapshot, while virtualbox was crashed
VBox.log Download (61.8 KB) - added by taisph 3 years ago.
Log from 4.1.2 crash

Change History

Changed 3 years ago by taisph

memtest snapshot, while virtualbox was crashed

comment:1 Changed 3 years ago by Technologov

Added myself as CC.

-Technologov

comment:2 Changed 3 years ago by frank

Still relevant with VBox 4.1.2?

comment:3 Changed 3 years ago by taisph

Yes, reproducible with both 4.0.12 and 4.1.2.

comment:4 Changed 3 years ago by frank

  • Version changed from VirtualBox 4.0.4 to VirtualBox 4.1.2

Could you attach a log file for a 4.1.2 session? Thank you!

Changed 3 years ago by taisph

Log from 4.1.2 crash

comment:5 Changed 22 months ago by frank

  • Description modified (diff)

Could you try with VBox 4.1.18? Also, does the same happen if you select the PIIX3 chipset instead of the (experimental) ICH9?

comment:6 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

The reporter does not use VirtualBox anymore.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use