VirtualBox

Ticket #8592 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

SATA DVD drive produces corruptions and crashes => fixed in svn

Reported by: unggnu Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description

If I try to install openSUSE with the virtual SATA dvd drive the installation hangs after a short time. When I install the system with rpm packages instead of a direct copy I directly get md5 checksum errors.

This problem doesn't appear if I use the virtual IDE drive so it looks like the DVD Sata implementation is broken.

I am using Virtualbox 4.0.4 on openSUSE 11.4 64 Bit.

Attachments

vbox.log Download (43.3 KB) - added by unggnu 3 years ago.

Change History

comment:1 Changed 3 years ago by frank

Could you attach a VBox.log file for both VM sessions?

Changed 3 years ago by unggnu

comment:2 Changed 3 years ago by unggnu

It should be easily reproducible with the openSUSE 11.4 DVD.

comment:3 Changed 3 years ago by frank

Could you apply r36972 and check if this fixes your problem?

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.8.

comment:5 Changed 3 years ago by verm

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've hit this bug myself installing Debian onto a VM using the following images with SATA and IntelAhci controller:

6.0.1a fails installing eject-udeb 2.1 with a "bad md5sum" error (hit alt-f2 and check /var/log/syslog in the non-gui installer.)

If I switch to IDE+ICH6 it installs fine, also switching back to SATA+IntelAhci after install appears to work just fine

6.0.1a, 6.0.1.2 fail in the same spot for i386+amd64.. 5.0.8 fails in a different spot for both i386/amd64.

comment:6 Changed 3 years ago by aeichner

Thanks for the report, I was able to reproduce the issue and will investigate it.

comment:7 Changed 3 years ago by aeichner

  • Summary changed from SATA DVD drive produces corruptions and crashes to SATA DVD drive produces corruptions and crashes => fixed in svn

Fixed the bug in svn. Only reading from DVD images bigger than 4GB was affected.

comment:8 Changed 3 years ago by verm

Thanks, I can confirm the bug has been fixed.

comment:9 Changed 3 years ago by verm

I should have mentioned in my original post, the  netinst CD fails as well which is only 400MB so there may be an entirely separate bug that caused it to trigger this bug.

With this patch it installs correctly.

comment:10 Changed 3 years ago by aeichner

I'm not able to reproduce the problem with netinstall iso even without the patch.

comment:11 Changed 3 years ago by frank

verm, which VBox version did you use when you observed the bug?

comment:12 Changed 3 years ago by verm

4.1.0 r37847 (beta 2) on FreeBSD 9-C last updated 2011-07-11.

comment:13 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix also contained in VBox 4.0.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use