VirtualBox

Ticket #8568 (new defect)

Opened 3 years ago

Last modified 3 years ago

Failed to create the VIrtualBox COM object TYPE_E_LIBNOTREGISTERED (0x8002801D)

Reported by: pawels Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords: TYPE_E_LIBNOTREGISTERED
Cc: Guest type: other
Host type: Windows

Description

I've just installed VirtualBox 4.0.4 on Windows 7 Home Premium 64-bit. When I run it I got following error message:


Failed to create the VirtualBox COM object. The applicatiion will now terminate.

Callee RC: TYPE_E_LIBNOTREGISTERED (0x8002801D)


When I try to use VBoxManage error message is more accurate:


c:\Program Files\Oracle\VirtualBox>VBoxManage.exe showvminfo VBoxManage.exe: error: Failed to create the VirtualBox object! VBoxManage.exe: error: Code TYPE_E_LIBNOTREGISTERED (0x8002801D) - Library not registered. (extended info not available) VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or failed to start.


It would be great if you could help resolve this issue. If you need more information please let me now.

Thanks in advance. Pawel

Change History

comment:1 Changed 3 years ago by pawels

I've tried to install previous releases of VirtualBox but the problem is the same.

comment:2 Changed 3 years ago by pawels

Using ProcessMonitor (SysInternals) I found entries with Result=ACCESS DENIED which pointed me exact registry key, which has no owner: *HKEY_CLASSES_ROOT\TypeLib\{46137EEC-703B-4FE5-AFD4-7C9BBBBA0259}

When I fix the missing permission all is working fine.

I don't understand why I had missing persmissions. I made installation as administrator and I run VirtualBox also as administrator

comment:3 Changed 3 years ago by edavies

I got the same error message after updating to the latest version of VirtualBox (4.1.4-74291). I use Windows 7 64-bit. How do I correct the permissions on that registry key? When I run regedit as an administrator, click on the HKEY_CLASSES_ROOT\TypeLib\{46137EEC-703B-4FE5-AFD4-7C9BBBBA0259}, and shows me an access denied error. Any suggestions to correct the error?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use