VirtualBox

Ticket #8478 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Event ID 9: did not respond within the timeout period

Reported by: ToddAndMargo Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

host: centos 5.5 x64, 32 GB memory guest: windows server 2003, sp2, r2 32 bit, 4 GB memory VM: VB 3.2.12

Hi All,

Sorry for coming directly to you guys with this, but since I can not purchase support from you guys, I have no other choice. And, this is a real emergency. I have got to get this fixed or my goose is cooked (as in fired).

I am in trouble here. I just got a Fox Pro database corruption. The SATA controller was giving me Event: 9 iaStor error out the nose, so I switched our controller from an "IATA89ENU v8.9.0.1023" (SATA) controller to a "Intel 82371AB/EB 5.2.3790.3959" (IDE/ATAPI) controller. It stopped the iaStor errors. But now I get the same Event:9 ATAPI errors.

I HAVE TO STOP THESE ERRORS!

Log files will follow shortly.

Many thanks, -T

Event Type: Error Event Source: atapi Event Category: None Event ID: 9 Date: 3/2/2011 Time: 10:21:14 AM User: N/A Computer: VB-PPRO2 Description: The device, \Device\Ide\IdePort0, did not respond within the timeout period.

Attachments

event9.zip Download (58.4 KB) - added by ToddAndMargo 3 years ago.
logs for event 9
WindowsXPE.7z Download (19.5 KB) - added by birdie 2 years ago.
The entire virtual machine, excluding a bootable Windows XP SP2 BartPE CD-Rom

Change History

Changed 3 years ago by ToddAndMargo

logs for event 9

comment:1 Changed 3 years ago by ToddAndMargo

I am finding this error all over my other Windows guests. Not a *flood* like the guest running M$SQL Server 2008, but here and there:

Event Type: Error Event Source: iaStor Event Category: None Event ID: 9 Date: 1/3/2011 Time: 1:54:23 PM User: N/A Computer: VB-WINXP Description: The device, \Device\Ide\iaStor0, did not respond within the timeout period.

Also: a work around to help you guys troubleshoot this issue:

Turn the Virtual Machine's hard drive cache off. Device Manager --> Disk drives --> VBOX HARDDRIVE --> Policies (tab) --> uncheck “Enable write caching on the disk”

This stopped the iaStor and ATAPI Event 9 errors. You guys now have something to fix.

-T

comment:2 Changed 3 years ago by frank

Any chance you test  this build? We fixed a guest corruption bug for SATA guests with high amount of guest RAM. There is a slight chance that your problem was related to that bug.

comment:3 Changed 3 years ago by ToddAndMargo

Hi Frank,

This bug fix sounds exciting and like it may fix the problem. Unfortunately, I can not test this fix as I no longer have access to this equipment: the customer fired me. This bug royally corrupted both an M$SQL 2008 and a Fox Pro database. I never managed to regain my customer confidence after that, even though I came up with a work around (uncheck “Enable write caching on the disk” ). This bug shows up in droves under M$SQL 2008.

Thank you for the help anyway, -T

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks, I so I will close this ticket.

comment:5 Changed 3 years ago by ToddAndMargo

Hi Frank,

Just out of curiosity, on what do you base closing the ticket? Is it because I can not test the patch and you do not like having bugs hanging around? Or, did you reproduce the problem and the patch fixed it?

Many thanks, -T

comment:6 Changed 3 years ago by frank

If you cannot test the fix then it does not make sense to keep it open. If you can reproduce the problem, feel free to reopen it.

comment:7 Changed 3 years ago by ToddAndMargo

Hi Frank,

Okay, I see. Labeling this as "fixed" is incorrect. You need to label it with something that correctly describes the situation. Do you have a "won't fix" or "unable to duplicate" or some such? Anything other than "fixed", which it is clearly not.

-T

comment:8 Changed 3 years ago by frank

I agree that fixed is not correct. OTOH, the current trac system does not provide an "unable to reproduce". But if someone has a similar issue he will read the last comments of this ticket and reopen it so I think this is not a big issue.

comment:9 Changed 2 years ago by birdie

  • Status changed from closed to reopened
  • Resolution fixed deleted

It's probably a Virtual Box 4.1.6 regression but this issue has resurfaced, I can reproduce it with Windows XP SP2,

iastor.sys 7.6.1.1002 iastor.inf 7.6.1.1002

It takes up to 2 minutes to initialize SATA HDD (real one, using a vmdk file) using this driver.

Changed 2 years ago by birdie

The entire virtual machine, excluding a bootable Windows XP SP2 BartPE CD-Rom

comment:10 Changed 2 years ago by birdie

Actually my problem is different - it takes up to two (2!!) minutes to initialize a SATA HDD, but then everything more or less works.

Shutdown also takes ages to complete.

comment:11 Changed 2 years ago by birdie

I've filed a new ticket 9859.

Please, close this one.

comment:12 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use