VirtualBox

Ticket #8420 (closed defect: fixed)

Opened 3 years ago

Last modified 20 months ago

Random lockups on linux guest

Reported by: Aketzu Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

I have Virtualbox 4.0.2 running on Linux (Debian, 2.6.35-trunk-amd64). There are several virtual machines (~20) running but only a few seem to exhibit random lockups. When that happens the guest becomes completely unresponsive (no ping, vrde screen is empty and unresponsive) and on host side guest consumes 100% CPU.

I've tried different guest kernels (2.6.32, .35, .37) but it always locks up eventually. Additionally the lockup is rather random but seems to occur daily (on one guest, on others maybe weekly). The difference between working and nonworking guests might be 64-bit kernel (not working) and 32-bit. Also the failing guests run weblogic app server whereas working servers run glassfish.

Everything worked fine on Virtualbox 3.2.x. Attached is log of about three lockups (+reboots) and shutdown on final lockup. I also have guest and VBox coredumps if somebody wants to take a look.

Attachments

VBox.log Download (95.2 KB) - added by Aketzu 3 years ago.

Change History

Changed 3 years ago by Aketzu

comment:1 Changed 3 years ago by Aketzu

Updated to 4.0.4 and it's still broken.

comment:2 Changed 3 years ago by frank

Could you check if  this build fixes your problem? There was a bug in the HPET emulation which could affect your problem.

comment:3 Changed 3 years ago by frank

Could you test VBox 4.0.6?

comment:4 Changed 3 years ago by Aketzu

I didn't notice the test build. I could have tried it during easter but now it's too late :)

I'll see whether I can test 4.0.6 during next weekend (or the next after that).

comment:5 Changed 3 years ago by Aketzu

Installed new version yesterday and so far it has worked. I want to wait for a while before calling it stable.

comment:6 Changed 3 years ago by Aketzu

One virtual machine locked up just as before so this issue still exists in 4.0.6

comment:7 Changed 3 years ago by frank

Could you perform another test with  this build? We fixed another bug which could be related to your problem as your VM uses the HPET timer.

comment:8 Changed 3 years ago by Aketzu

Updated to 4.0.8 (and just a day before 4.0.10 was released...) and just had the same VM lock up again.

comment:9 Changed 3 years ago by frank

  • Version changed from VirtualBox 4.0.2 to VirtualBox 4.0.8

comment:10 Changed 22 months ago by frank

  • Description modified (diff)

Another test could be to use the PIIX3 chipset instead of the ICH9 chipset as the latter is still marked as experimental.

comment:11 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use