VirtualBox

Ticket #838 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Mounting CD inside VM fails first time after changing image

Reported by: fjp Owned by:
Priority: major Component: DVD
Version: VirtualBox 1.5.2 Keywords: Linux CD
Cc: Guest type: other
Host type: other

Description

I boot the installer using with the VM's CD pointing to an ISO CD image (CD1). During the installation I need to switch to a different image (CD2). Even if I do that procedure completely manually, the first mount command will always fail.

# umount /cdrom
/* use virtual disk manager to change CD ISO image */
# mount /dev/hdc /cdrom
mount: you must specify the filesystem type
# mount /dev/hdc /cdrom
mount: block device /dev/hdc is write-protected, mounting read-only
/* use virtual disk manager to change CD ISO image */
# mount /cdrom
mount: no medium found
# mount /cdrom
mount: block device /dev/hdc is write-protected, mounting read-only
# umount /cdrom

There is one strange thing: I can only reproduce this when using the Debian kernel compiled for a 486 processor (which is the one used in the Installer), not with the one compiled for a 686 processor. I can provide the kernel configs if needed.

I first experienced the problem during installation, but also reproduced it in an installed Debian system after booting it with the 486 kernel.

As this problem does not occur in vmware, I think it must be an issue in VirtualBox.

Context: Using a Debian Installer CD image to install a new system
Host system: Pentium D SMP x86_64 system running Linux 2.6.23
VM: VirtualBox 1.5.2 running 2.6.22 kernel

This report is based on my mail to the user list:
 http://vbox.innotek.de/pipermail/vbox-users/2007-October/002362.html

Change History

comment:1 Changed 6 years ago by fjp

The comment that the problem cannot be reproduced with a kernel compiled for a 686 processor is incorrect. I'm not sure why I could not reproduce it with that initially as I can reproduce it reliably now.

I've also tested that with a current 2.6.24 kernel the issue is still there, so it really looks like this is something in VirtualBox.

comment:2 Changed 6 years ago by frank

  • Component changed from other to DVD

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem is still reproducible with VBox 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use