Opened 13 years ago

Closed 8 years ago

#8362 closed defect (obsolete)

Failed to create host-only network interface in 4.0.4 under Win 7 x64 => Fixed in SVN

Reported by: Jim Heck Owned by:
Component: network Version: VirtualBox 4.0.4
Keywords: Cc:
Guest type: Windows Host type: Windows

Description (last modified by aeichner)

I just installed the upgrade from 4.0.2 to 4.0.4. I am running a Windows 7 64 Ultimate host and a Windows XP guest. I had had a host only network interface configured, and was using it successfully with this guest. That interface is now gone following upgrade, and when I try to recreate it, there is an error. I was previously having problems previously with DHCP (or lack thereof) on the host-only network interface. Now I can't seem to use it at all.

I will attach a JPG with the error dialog. The gist is an assertion that the access was denied to create the interface "COM RC = E_ACCESSDENIED (0x80070005). The error dialog shows up immediately and then I see Win 7 pop up an administrator dialog indicating that Virtualbox would like to make changes to the computer, but by this point it seems Virtualbox has already given up and nothing ever gets added.

I have tried rebooting. I also tried starting the Virtualbox application with administrator privileges, but the same error dialog appears (but there is no pop-up from Win 7 asking permission to make changes).

Best Regards,

-Jim Heck

Attachments (2)

hostnetwork.jpg (100.4 KB ) - added by Jim Heck 13 years ago.
Error dialog
virtualbox_machine_startup.png (14.8 KB ) - added by Rick Morris 13 years ago.
Virtual machine startup crash

Download all attachments as: .zip

Change History (13)

by Jim Heck, 13 years ago

Attachment: hostnetwork.jpg added

Error dialog

comment:1 by Rick Morris, 13 years ago

I have exactly the same issue. Cannot create a host-only network interface with the identical error message to the above (Windows 7 64-bit, running on a Dell Inspiron 1764). Host-only networking worked fine with 4.0 and 4.0.2, but now my virtual machines crash on startup with the error "Failed to open a session for the virtual machine" (see attachment following).

by Rick Morris, 13 years ago

Virtual machine startup crash

comment:2 by Aleksey Ilyushin, 13 years ago

Summary: Failed to create host-only network interface in 4.0.4 under Win 7 x64Failed to create host-only network interface in 4.0.4 under Win 7 x64 => Fixed in SVN

comment:3 by Nephi Johnson, 13 years ago

I'm seeing this as well (also on an x64 Win7 Host). I was in a very similar situation where the Host-Only DHCP wasn't working anymore for my Host machine (was constantly getting IP addresses of 169.* instead of the that I configured it for). I tried re-installing/repairing VirtualBox thinking it might fix the problem, and now the Host-Only interface is completely gone. Trying to add it through Preferences->Network->Add Host-Only-Network fails with the same error described above.

comment:4 by Nephi Johnson, 13 years ago

Just FYI, completely uninstalling VirtualBox 4.0.4 and then reinstalling it seems to have made the Host-only network adapter come back online.

comment:5 by Nephi Johnson, 13 years ago

Well, sorry for the non-working workaround - it looked like it was working for a few minutes, but the Host-only network adapter on my x64 Win7 host went back to only having ip addresses in the 169.* range. Bummer. Workaround FAIL. Trying to do "ipconfig /release *Box*" or "ipconfig /renew *Box*" gives me this error:

Adapter VirtualBox Host-Only Network is not enabled for DHCP.

comment:6 by Phoebe, 13 years ago

I was getting this error as well when trying to create additional host-only network adapters. I quit VirtualBox and restarted using "Run as Administrator" and noticed that all the adapters I had attempted to add were now visible and I could assign them to NICs on my VMs.

Note that I always had ONE host-only network adapter (the one created when installing VirtualBox)

I guess this is a workaround for some people.

comment:7 by Frank Mehnert, 13 years ago

Resolution: fixed
Status: newclosed

comment:8 by Adam Piper, 13 years ago

Resolution: fixed
Status: closedreopened

This seems to be happening in 4.1.2 on Win 7 64bit.

comment:9 by usver, 10 years ago

I'm tired of this problem. Three days and I can't decide it. I use vagrant and when try to use static ip virtualbox is crashes. Virtualbox DOES NOT create host-only network adapter.

Код ошибки: E_FAIL (0x80004005) Компонент: VirtualBox Интерфейс: IVirtualBox {fafa4e17-1ee2-4905-a10e-fe7c18bf5554}

It doesn't create adapter nither via own GUI nor via Vagrant CLI.

The latest version of virtualbox for today (4.3.8 r92456)

At first time this helped me - But when I decided to repeat process I got the error again.

Last edited 10 years ago by usver (previous) (diff)

comment:10 by Mitch K, 10 years ago

We are suffering the same issue at my office, I have asked the following question in SuperUser website - at first we thought it was a windows permissions issue but our sysadmin is adamant that he has exactly the same permissions as me, so...

1) if there was any 'fix' to this issue, perhaps it would also help us

2) if still no fix, perhaps the fact we have two seemingly identical machines, but one has the issue and one doesn't, means that we have a good basis for comparison and determining where the issue lies.

The question on the superuser site is here for reference.

Many thanks, Mitch.

-- Version: 4.3.10 r93012 / Win 7 64b

Last edited 10 years ago by Mitch K (previous) (diff)

comment:11 by aeichner, 8 years ago

Description: modified (diff)
Resolution: obsolete
Status: reopenedclosed

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use