VirtualBox

Ticket #8359 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

vboxdrv setup failed in gentoo - VirtualBox-4.0.4-70112-Linux_amd64

Reported by: upengan78 Owned by:
Priority: major Component: installer
Version: VirtualBox 4.0.4 Keywords: vboxdrv
Cc: Guest type: other
Host type: Linux

Description

Hello,

I am using gentoo, kernel - 2.6.35-gentoo-r8 , AMD64

I was able to install this Virtualbox version successfully but when I ran /etc/init.d/vboxdrv setup, it shows below messages and fails.

 * Stopping VirtualBox kernel modules ...                                                                                                             [ ok ]
 * Uninstalling old VirtualBox DKMS kernel modules ...                                                                                                [ !! ]
 * Trying to register the VirtualBox kernel modules using DKMS ...
 * Failed, trying without DKMS
 * Recompiling VirtualBox kernel modules ...
 * Look at /var/log/vbox-install.log to find out what went wrong

cat /var/log/vbox-install.log

make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.4 SRCROOT=/tmp/vbox.4 -C /lib/modules/2.6.35-gentoo-r8/build modules
make[1]: *** No rule to make target `modules'.  Stop.
make: *** [vboxdrv] Error 2

If you can assist, that will be great.

Thanks!

Attachments

strace.txt Download (73.4 KB) - added by upengan78 3 years ago.
strace /etc/init.d/vboxdrv setup

Change History

Changed 3 years ago by upengan78

strace /etc/init.d/vboxdrv setup

comment:1 Changed 3 years ago by upengan78

I have upgraded kernel on my system to 2.6.36-gentoo-r5 and reinstalled this version of Virtualbox, everything worked fine. I am sorry for the trouble as it looks like issue on my system.

You may want to close this ticket/bug.

Thanks

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for letting us know.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use